Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#40164 closed defect (fixed)

eric4 @4.5.5_2: destroot tries to write to /Developer

Reported by: michael_herrmann@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc:
Port: eric4

Description

Although started with 'sudo install eric4' the log file says:

OSError: [Errno 1] Operation not permitted: '/Developer/Applications/Eric4'

Attachments (1)

main.log (73.8 KB) - added by michael_herrmann@… 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by michael_herrmann@…

Attachment: main.log added

comment:1 Changed 6 years ago by michael_herrmann@…

btw. OS is Snow Leopard

comment:2 Changed 6 years ago by cooljeanius (Eric Gallager)

Looks like sandboxing...

comment:3 Changed 6 years ago by larryv (Lawrence Velázquez)

Keywords: permission removed
Summary: 'Staging eric4 into destroot' failseric4 @4.5.5_2: destroot tries to write to /Developer
:info:destroot Traceback (most recent call last):
:info:destroot   File "install.py", line 1059, in <module>
:info:destroot     main(sys.argv)
:info:destroot   File "install.py", line 1002, in main
:info:destroot     installEric()
:info:destroot   File "install.py", line 509, in installEric
:info:destroot     createMacAppBundle(cfg['ericDir'])
:info:destroot   File "install.py", line 524, in createMacAppBundle
:info:destroot     os.makedirs(dirs["contents"])
:info:destroot   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/os.py", line 150, in makedirs
:info:destroot     makedirs(head, mode)
:info:destroot   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/os.py", line 150, in makedirs
:info:destroot     makedirs(head, mode)
:info:destroot   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/os.py", line 157, in makedirs
:info:destroot     mkdir(name, mode)
:info:destroot OSError: [Errno 1] Operation not permitted: '/Developer/Applications/Eric4'

Is the destroot phase trying to create that directory? It should not be attempting to create any files outside of the destroot directory. If this is the situation, then the sandbox is working as intended, and the port needs to be fixed.

comment:4 in reply to:  3 Changed 6 years ago by michael_herrmann@…

Replying to larryv@…:

:info:destroot Traceback (most recent call last):
:info:destroot   File "install.py", line 1059, in <module>
:info:destroot     main(sys.argv)
:info:destroot   File "install.py", line 1002, in main
:info:destroot     installEric()
:info:destroot   File "install.py", line 509, in installEric
:info:destroot     createMacAppBundle(cfg['ericDir'])
:info:destroot   File "install.py", line 524, in createMacAppBundle
:info:destroot     os.makedirs(dirs["contents"])
:info:destroot   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/os.py", line 150, in makedirs
:info:destroot     makedirs(head, mode)
:info:destroot   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/os.py", line 150, in makedirs
:info:destroot     makedirs(head, mode)
:info:destroot   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/os.py", line 157, in makedirs
:info:destroot     mkdir(name, mode)
:info:destroot OSError: [Errno 1] Operation not permitted: '/Developer/Applications/Eric4'

Is the destroot phase trying to create that directory? It should not be attempting to create any files outside of the destroot directory. If this is the situation, then the sandbox is working as intended, and the port needs to be fixed.

Yes, that's the case. I didn't know anything about sandboxing and I tried to create that dir manually. Afterwards it failed creating /Developer/Applications/Eric4/Contents.

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:6 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

comment:7 Changed 6 years ago by michael_herrmann@…

works, great, thanks

Note: See TracTickets for help on using tickets.