Opened 9 years ago

Last modified 3 years ago

#40190 assigned defect

Trac wiki page deleted messages are not correct

Reported by: ryandesign (Ryan Schmidt) Owned by: admin@…
Priority: Normal Milestone:
Component: trac Version:
Keywords: upstream Cc: raimue (Rainer Müller)
Port:

Description

The email messages telling us when a version of a wiki page is deleted are not correct. Today spam was added to three pages. Those revisions were then promptly deleted, but the messages sent stated:

Version "58" of page "Migration" was deleted by ajh158@yahoo.com
Version "9" of page "MisbehavingServers" was deleted by ecronin@macports.org
Version "6" of page "SpecialMaintainerAddresses" was deleted by ryandesign@macports.org

In each case, the individual named is not the one who deleted the offending revision, but the one who wrote the most recent remaining revision of the page.

Change History (7)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

This problem is still happening. Is this a Trac bug that needs to be reported to the Trac developers, or a bug in a plugin we're using?

comment:2 Changed 8 years ago by jmroot (Joshua Root)

Owner: changed from wsiegrist@… to admin@…

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from admin@… to admin@…
Status: newassigned

comment:4 Changed 6 years ago by raimue (Rainer Müller)

Cc: raimue added

Looks like this is still wrong even after updating to Trac 1.0:

https://lists.macosforge.org/pipermail/macports-changes/2016-November/142276.html

Definitely something we need to report upstream.

comment:5 Changed 5 years ago by raimue (Rainer Müller)

It is definitely a bug in the WikiNotification plugin.

Upstream: https://github.com/trac-hacks/trac-wikinotification/issues/11

comment:6 Changed 5 years ago by neverpanic (Clemens Lang)

Component: server/hostingtrac
Keywords: upstream added

comment:7 Changed 3 years ago by ryandesign (Ryan Schmidt)

Rainer, the upstream issue you filed was closed when the fix you proposed was merged in October 2017, yet we still have this problem on our Trac. Can we apply the fix to our copy of the plugin or do we need them to release a new version of it?

Note: See TracTickets for help on using tickets.