Opened 8 years ago

Closed 8 years ago

#40689 closed defect (duplicate)

R @3.0.2_0 +accelerate +cairo +gfortran48 +recommended +x11 Compile error

Reported by: grischa.toedt@… Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc:
Port: R

Description

Hi,

on my system i have:

sh-3.2# port select --list gcc
Available versions for gcc:
	llvm-gcc42
	mp-gcc47
	mp-gcc48 (active)
	none

after "port selfupdate", "port upgrade outdated", "port clean R" i try a "port install R +accelerate +cairo +gfortran48 +recommended +x11" and i get:

...
:info:build f951: internal compiler error: Illegal instruction: 4
:info:build
:info:build f951: internal compiler error: Abort trap: 6
:info:build /opt/local/bin/gfortran-mp-4.8   -fPIC  -pipe -Os -m64  -c dposl.f -o dposl.o
:info:build /opt/local/bin/gfortran-mp-4.8   -fPIC  -pipe -Os -m64  -c dqrdc.f -o dqrdc.o
:info:build f951: internal compiler error: Illegal instruction: 4
:info:build
:info:build f951: internal compiler error: Abort trap: 6
:info:build gfortran-mp-4.8: internal compiler error: Abort trap: 6 (program f951)
:info:build gfortran-mp-4.8: internal compiler error: Abort trap: 6 (program f951)
:info:build make[3]: *** [dpofa.o] Abort trap: 6
:info:build make[3]: *** Deleting file `dpofa.o'
:info:build make[3]: *** Waiting for unfinished jobs....
:info:build make[3]: *** [dqrdc.o] Abort trap: 6
:info:build make[3]: *** Deleting file `dqrdc.o'
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src/appl'
:info:build make[2]: *** [R] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src/appl'
:info:build make[1]: *** [R] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src'
:info:build make: *** [R] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2" && /usr/bin/make -j2 -w all
:info:build Exit code: 2
:error:build org.macports.build for port R returned: command execution failed
:debug:build Error code: CHILDSTATUS 76211 2
:debug:build Backtrace: command execution failed

the full log is attached...

Any suggestions?

Attachments (1)

main.log (204.3 KB) - added by grischa.toedt@… 8 years ago.
R install log

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by grischa.toedt@…

Attachment: main.log added

R install log

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to kjell.konis@…
Port: R added

comment:2 Changed 8 years ago by kjellpk (Kjell Konis)

Hmmm. Not sure what's going wrong. gfortran-mp-4.8 is able to compile both of these files on both my Mountain Lion and Snow Leopard test machines. Does it work if you use the gfortran47 variant? e.g.

$ sudo port install R +gfortran47

comment:3 in reply to:  2 Changed 8 years ago by grischa.toedt@…

Tried to use the +gfortran47 variant, the same error occurs (both setting gcc to mp-gcc47 or letting it mp-gcc48):

:info:build make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src/appl'
:info:build /opt/local/bin/gfortran-mp-4.7   -fPIC  -pipe -Os -m64  -c dpofa.f -o dpofa.o
:info:build /opt/local/bin/gfortran-mp-4.7   -fPIC  -pipe -Os -m64  -c dposl.f -o dposl.o
:info:build f951: internal compiler error: Illegal instruction: 4
:info:build Please submit a full bug report,
:info:build with preprocessed source if appropriate.
:info:build See <https://trac.macports.org/newticket> for instructions.
:info:build make[3]: *** [dpofa.o] Error 1
:info:build make[3]: *** Waiting for unfinished jobs....
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src/appl'
:info:build make[2]: *** [R] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src/appl'
:info:build make[1]: *** [R] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2/src'
:info:build make: *** [R] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_R/R/work/R-3.0.2" && /usr/bin/make -j2 -w all 
:info:build Exit code: 2
:error:build org.macports.build for port R returned: command execution failed
:debug:build Error code: CHILDSTATUS 11652 2
:debug:build Backtrace: command execution failed

comment:4 Changed 8 years ago by kjellpk (Kjell Konis)

Perhaps a duplicate of, or related to #40439. You wouldn't happen to have a dual core 64 bit core 2 duo would you?

comment:5 Changed 8 years ago by grischa.toedt@…

Yes i have a Intel Core 2 Duo with 2.66GHz and 3MB L2 Cache.
So you say it is an upstream bug in gfortran, related to the optflags?

On my system i was able to compile both gcc48 and libgcc, thats different from #40439.

What can i do to help tracking it further down?

comment:6 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.