Opened 6 years ago

Closed 6 years ago

#40770 closed defect (fixed)

metasploit3: Error: Dependency 'rb-libglade2' not found

Reported by: hbhotz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: cooljeanius (Eric Gallager), kimuraw (kimura wataru), opendarwin.org@…
Port: metasploit3

Description (last modified by ryandesign (Ryan Schmidt))

There appears to no longer be a rb-libglade2 port in existence.

hotz$ sudo port install metasploit3
--->  Computing dependencies for metasploit3
Error: Dependency 'rb-libglade2' not found.
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port metasploit3 failed
hotz$

Change History (3)

comment:1 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: kimuraw@… opendarwin.org@… added
Description: modified (diff)
Port: metasploit3 added
Summary: Unavailable Dependencies for metasploit3 Portmetasploit3: Error: Dependency 'rb-libglade2' not found

kimuraw deleted rb-libglade2 in r111612, but his wiki page says he still maintains it.

Even if this were fixed you'll probably have other problems with metasploit3. #24103 says it's out of date -- and that ticket was filed 4 years ago.

comment:3 Changed 6 years ago by kimuraw (kimura wataru)

Resolution: fixed
Status: newclosed

added rb-libglade2 and its depedencies at r112278.

NOTE: ruby-gnome2 project deprecated ruby/libglade2.

Note: See TracTickets for help on using tickets.