Opened 5 years ago

Closed 5 years ago

#40930 closed defect (duplicate)

octave-devel 3.6.4_8 does not build on Mavericks

Reported by: tenomoto (Takeshi Enomoto) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: haspatch Cc: roberthuston@…, michaelbartz@…, damian@…, lawrence.ong@…, ralph@…, iqgrande, lpsinger (Leo Singer), onurdomanic@…, marcs@…, skymoo (Adam Mercer), davydden@…
Port: octave-devel

Description

Mavericks also needs patch-src-display.cc.diff. The attached patch (Portfile.diff) checks ${os.version} rather than adding another platform. I also needed to patch configure to avoid a failure in finding std::unordered_map (patch-configure.diff).

Attachments (2)

Portfile.diff (1.5 KB) - added by tenomoto (Takeshi Enomoto) 5 years ago.
patch-configure.diff (231 bytes) - added by tenomoto (Takeshi Enomoto) 5 years ago.

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by tenomoto (Takeshi Enomoto)

Attachment: Portfile.diff added

Changed 5 years ago by tenomoto (Takeshi Enomoto)

Attachment: patch-configure.diff added

comment:1 Changed 5 years ago by roberthuston@…

Cc: roberthuston@… added

Cc Me!

comment:2 Changed 5 years ago by michaelbartz@…

Cc: michaelbartz@… added

Cc Me!

comment:3 Changed 5 years ago by damian@…

Cc: damian@… added

Cc Me!

comment:4 Changed 5 years ago by lawrence.ong@…

Cc: lawrence.ong@… added

Cc Me!

comment:5 Changed 5 years ago by ralph@…

Cc: ralph@… added

Cc Me!

comment:6 Changed 5 years ago by iqgrande

Cc: iqgrande@… added

Cc Me!

comment:7 Changed 5 years ago by lpsinger (Leo Singer)

Cc: aronnax@… added

Cc Me!

comment:8 Changed 5 years ago by onurdomanic@…

Cc: onurdomanic@… added

Cc Me!

comment:9 Changed 5 years ago by marcs@…

Cc: marcs@… added

Cc Me!

comment:10 Changed 5 years ago by davydden@…

Cc Me!

comment:11 Changed 5 years ago by skymoo (Adam Mercer)

Cc: ram@… added

Cc Me!

comment:12 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: davydden@… added

comment:13 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #40806.

Note: See TracTickets for help on using tickets.