Opened 4 years ago

Closed 4 years ago

#40963 closed defect (duplicate)

gstreamer1 faild buil with Mavericks and Port 2.2.1

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: gstreamer1

Description

sudo port upgrade outdated
--->  Computing dependencies for gstreamer1
--->  Building gstreamer1
Error: org.macports.build for port gstreamer1 returned: command execution failed
Please see the log file for port gstreamer1 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/main.log
Error: Problem while installing gstreamer1

:info:build <command line>:4:22: note: expanded from here
:info:build #define G_LOG_DOMAIN g_log_domain_gstreamer
:info:build                      ^
:info:build   CC     libgstreamer_1.0_la-gstelement.lo
:info:build   CC     libgstreamer_1.0_la-gstelementfactory.lo
:info:build 5 errors generated.
:info:build make[4]: *** [libgstreamer_1.0_la-gstdatetime.lo] Error 1
:info:build make[4]: *** Waiting for unfinished jobs....
:info:build make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/work/gstreamer-1.0.9/gst'
:info:build make[3]: *** [all-recursive] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/work/gstreamer-1.0.9/gst'
:info:build make[2]: *** [all] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/work/gstreamer-1.0.9/gst'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/work/gstreamer-1.0.9'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/work/gstreamer-1.0.9'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gstreamer1/gstreamer1/work/gstreamer-1.0.9" && /usr/bin/make -j8 -w all CC="/usr/bin/clang -arch x86_64"
:info:build Exit code: 2
:error:build org.macports.build for port gstreamer1 returned: command execution failed
:debug:build Error code: '''CHILDSTATUS 22854 2'''
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"

Change History (1)

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Keywords gstreamer1 removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40783.

Note: See TracTickets for help on using tickets.