Opened 4 years ago

Closed 10 months ago

#40980 closed defect (fixed)

sbcl problems with non-ascii chars in dirname

Reported by: cielartisan@… Owned by: easye
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks Cc: gwright@…, Themanwithoutaplan
Port: sbcl

Description (last modified by ryandesign (Ryan Schmidt))

--->  Fetching archive for sbcl
--->  Attempting to fetch sbcl-1.1.12_0.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/sbcl
--->  Attempting to fetch sbcl-1.1.12_0.darwin_13.x86_64.tbz2 from http://packages.macports.org/sbcl
--->  Attempting to fetch sbcl-1.1.12_0.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/sbcl
--->  Fetching distfiles for sbcl
--->  Verifying checksums for sbcl
--->  Extracting sbcl
--->  Applying patches to sbcl
--->  Configuring sbcl
--->  Building sbcl
Error: org.macports.build for port sbcl returned: command execution failed
Please see the log file for port sbcl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_sbcl/sbcl/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port sbcl failed

Attachments (1)

main.log (4.9 MB) - added by cielartisan@… 4 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_sbcl/sbcl/main.log

Change History (14)

Changed 4 years ago by cielartisan@…

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_sbcl/sbcl/main.log

comment:1 Changed 4 years ago by cielartisan@…

Sorry version is 2.2.1...

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Cc gwright@… added
  • Description modified (diff)
  • Owner changed from macports-tickets@… to easieste@…
  • Port sbcl added
  • Version changed from 2.2.0 to 2.2.1

comment:3 Changed 4 years ago by easye

sbcl-1.1.12 builds for me without errors.

According to the log provided, the build succeeds, but fails in the SB-POSIX-TESTS::READDIR.1:

:info:build Test SB-POSIX-TESTS::READDIR.1 failed
:info:build Form: (LET ((SB-POSIX-TESTS::DIR (SB-POSIX:OPENDIR "/")))
:info:build         (UNWIND-PROTECT
:info:build             (BLOCK SB-POSIX-TESTS::DIR-LOOP
:info:build               (LOOP SB-POSIX-TESTS::FOR SB-POSIX-TESTS::DIRENT = (SB-POSIX:READDIR
:info:build                                                                   SB-POSIX-TESTS::DIR)
:info:build                     SB-POSIX-TESTS::UNTIL (NULL-ALIEN SB-POSIX-TESTS::DIRENT)
:info:build                     WHEN (NOT
:info:build                           (STRINGP
:info:build                            (SB-POSIX:DIRENT-NAME SB-POSIX-TESTS::DIRENT)))
:info:build                     DO (RETURN-FROM SB-POSIX-TESTS::DIR-LOOP NIL)
:info:build                     SB-POSIX-TESTS::FINALLY (RETURN T)))
:info:build           (SB-POSIX:CLOSEDIR SB-POSIX-TESTS::DIR)))
:info:build Expected value: T
:info:build Actual value: #<SB-INT:C-STRING-DECODING-ERROR {1004947773}>.

where SBCL attempts to iterate over the directory entries of the root filesystem "/", failing when any entry is not a string. I speculate that the originating bug report has some "funky" entries in the root directory that SBCL isn't dealing with very well.

@cielartisan: could you check your root directory to see if it has anything "weird" in it? If possible, it might help to know what the contents of "ls -1a /" returns.

In general, I don't expect this bug to affect many other users of SBCL, but I will endeavor to figure out what is "special" about the reporters case, getting feedback from SBCL maintainers if necessary.

comment:4 Changed 4 years ago by cielartisan@…

ls -1a / returns:

.
..
.DS_Store
.DocumentRevisions-V100
.PKInstallSandboxManager
.Spotlight-V100
.Trashes
.dbfseventsd
.file
.fseventsd
.vol
Applications
Library
Network
System
Users
Volumes
bin
cores
dev
etc
home
mach_kernel
net
opt
pkg
private
sbin
src
tmp
uninstall.command
usr
var
ユーザ情報

Well, this ユーザ情報 is symlink to /Library/Documentation/ユーザ情報, which contains ENERGY STAR.pdf. Moving the directory indeed solves the problem temporary, but it will cause an issue during the next update of sbcl (until binary package is provided).

comment:5 Changed 4 years ago by cielartisan@…

Anyway this issue is very rare and happens mostly to only Asians, so this issue can be closed as MacPorts issue...

Thank you so much.

Last edited 4 years ago by cielartisan@… (previous) (diff)

comment:6 Changed 4 years ago by easye

  • Resolution set to wontfix
  • Status changed from new to closed

A known bug in SBCL, cf. https://bugs.launchpad.net/sbcl/+bug/601576 .

The problem is larger than "happens mostly to only Asians": I would expect this to give problems to anyone using a filesystem with non-ISO-8859-1 encodings.

I am closing as "wontfix", but it would be possible to address this with a patch to ignore the results of this test if a significant number of people object to sweeping things under the rug.

comment:7 Changed 4 years ago by easye

  • Summary changed from sbcl fails on OSX Mavericks to sbcl problems with non-ascii chars in dirname

comment:8 Changed 4 years ago by cielartisan@…

Alright. Thank you so much. If sbcl's official fix doesn't come, I just hope we'll have binary package later.

comment:9 Changed 4 years ago by cielartisan@…

sbcl 1.1.13 came before you release binary package... I really need binary package so that I will not have to struggle with this issue. When will the buildbot ready?

comment:10 Changed 3 years ago by Themanwithoutaplan

  • Cc charlie.clark@… added

Cc Me!

comment:11 Changed 3 years ago by Themanwithoutaplan

What a weird error! There is a workaround: just rename the files during the build. On the German system the following is sufficient:

mv /Benutzerhandbücher\ und\ Informationen /Benutzerhandbuecher\ und\ Informationen

comment:12 Changed 10 months ago by easye

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:13 Changed 10 months ago by easye

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.