Opened 4 years ago

Last modified 4 years ago

#41282 new defect

wine: Assertion failed at address 0x000b:0x9938f952 (thread 0009), starting debugger...

Reported by: ph.schaefe@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks Cc: jyrkiwahlstedt
Port: wine

Description

Dear Sirs

after upgrading from Lion to Mavericks, I had to reinstall the MacPorts (I notice that Mavericks instantly improved the flickering bug in fullscreen games with Wine on a MacBook), as MacPorts refused to update the outdated ports.

So I also had to reinstall Wine and Winetricks.

But, unfortunately, one of my more important applications, OriginPro 8, now instantly crashes when I click in its menu bar. It was working quite alright with the old install of Wine.

Upon crashing, it says:

Assertion failed at address 0x000b:0x9938f952 (thread 0009), starting debugger...

But the debugger neither ever finishes nor does it tell me anything.

Best regards Philipp

Change History (5)

comment:1 Changed 4 years ago by ph.schaefe@…

The program freezes when I click on the "File" menu. Clicking on all the other menu items, e.g. "Edit", "Window" or "Help", does not result in freezing. And OriginPro 8.51 crashes in the same way.

Maybe it has something to do with another error message that is displayed by Wine while the OriginPro still runs.

fixme:storage:create_storagefile Storage share mode not implemented.

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… openmaintainer@… removed
  • Owner changed from macports-tickets@… to ryandesign@…
  • Summary changed from Assertion failed at address 0x000b:0x9938f952 (thread 0009), starting debugger... to wine: Assertion failed at address 0x000b:0x9938f952 (thread 0009), starting debugger...

Please confirm that you are running Xcode 5.0.1 and the corresponding version of its command line tools. If so, then please report this crash to the developers of wine; we at MacPorts are not responsible for wine's code.

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

First, you may want to try the wine-devel port instead; it's a newer development version of wine that may already fix this problem.

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Is there any change in this issue? If you resolved it, let us know how. If you reported it to the developers, let us know the URL of that report.

comment:5 Changed 4 years ago by ph.schaefe@…

Hello again, and thank you for looking after this.

Wine-devel didn't help much, but I quite like it though. I'm working around the problem with two wineprefixes, one that remains unchanged, and a normal one for my other stuff.

Here is the Wine ticket link: http://bugs.winehq.org/show_bug.cgi?id=34888

Note: See TracTickets for help on using tickets.