Opened 6 years ago

Closed 6 years ago

#41475 closed defect (fixed)

php: br.php.net mirror returns html file and checksum mismatch

Reported by: theboergers@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: php

Description (last modified by ryandesign (Ryan Schmidt))

Unable to update php55 to 5.5.6. Cleaned the port and tried again with the same results. Looked at the sites and the build for 10.9 (php55-5.5.6_0+libedit.darwin_13.x86_64.tbz2) doesn't exist in the mirrors.

The output:

[~] : portup
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.2.1 installed,
MacPorts base version 2.2.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
--->  Computing dependencies for php55
--->  Fetching archive for php55
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports.
--->  Attempting to fetch php55-5.5.6_0+libedit.darwin_13.x86_64.tbz2 from http://packages.macports.org/php55
--->  Attempting to fetch php55-5.5.6_0+libedit.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/php55
--->  Attempting to fetch php55-5.5.6_0+libedit.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/php55
--->  Fetching distfiles for php55
--->  Attempting to fetch php-5.5.6.tar.xz from http://br.php.net/get/php-5.5.6.tar.xz/from/this/mirror?dummy=
--->  Verifying checksums for php55
Error: Checksum (md5) mismatch for php-5.5.6.tar.xz
Error: Checksum (rmd160) mismatch for php-5.5.6.tar.xz
Error: Checksum (sha256) mismatch for php-5.5.6.tar.xz
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
The file has been moved to: /opt/local/var/macports/distfiles/php5/php-5.5.6.tar.xz.html
Error: org.macports.checksum for port php55 returned: Unable to verify file checksums
Please see the log file for port php55 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_php/php55/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

Attachments (1)

php-5.5.6.tar.xz.html (5.5 KB) - added by theboergers@… 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: php added
Status: newassigned

comment:2 in reply to:  description Changed 6 years ago by ryandesign (Ryan Schmidt)

Summary: 10.9 build of PHP 5.5.6 missing in mirrorsphp: br.php.net mirror returns html file and checksum mismatch

Replying to theboergers@…:

Looked at the sites and the build for 10.9 (php55-5.5.6_0+libedit.darwin_13.x86_64.tbz2) doesn't exist in the mirrors.

We just set up the Mavericks buildbot a few days ago. It will take several more days before it has finished building all ports.

It's not a problem if a binary is not available. In that case, MacPorts will try to download and build the source. The problem is that that is failing for you.

--->  Fetching distfiles for php55
--->  Attempting to fetch php-5.5.6.tar.xz from http://br.php.net/get/php-5.5.6.tar.xz/from/this/mirror?dummy=
--->  Verifying checksums for php55
Error: Checksum (md5) mismatch for php-5.5.6.tar.xz
Error: Checksum (rmd160) mismatch for php-5.5.6.tar.xz
Error: Checksum (sha256) mismatch for php-5.5.6.tar.xz
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
The file has been moved to: /opt/local/var/macports/distfiles/php5/php-5.5.6.tar.xz.html

Please attach this html file so that I can see what the problem was.

Changed 6 years ago by theboergers@…

Attachment: php-5.5.6.tar.xz.html added

comment:3 Changed 6 years ago by theboergers@…

File attached.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Thanks. Looks like br.php.net no longer resolves. I've removed the br.php.net mirror in r113619.

To avoid this problem in the future, you may want to switch to a DNS server that is not broken.

Note: See TracTickets for help on using tickets.