New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #41498 (closed defect: fixed)

Opened 17 months ago

Last modified 13 months ago

lirc build failure on 10.8

Reported by: ctreleaven@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: christian-narr@…, me@…
Port: lirc

Description

:info:build Undefined symbols for architecture x86_64:
:info:build   "_expectone", referenced from:
:info:build       _get_data in receive.o
:info:build   "_expectzero", referenced from:
:info:build       _get_data in receive.o
:info:build   "_get_header", referenced from:
:info:build       _receive_decode in receive.o
:info:build      (maybe you meant: _get_header_length)
:info:build   "_get_repeat", referenced from:
:info:build       _receive_decode in receive.o
:info:build      (maybe you meant: _get_repeat_length)
:info:build   "_sync_rec_buffer", referenced from:
:info:build       _receive_decode in receive.o
:info:build ld: symbol(s) not found for architecture x86_64

XCode 5.0.2 on 10.8.5

Attachments

main.log (27.8 KB) - added by ctreleaven@… 17 months ago.
patch-lirc_2013Nov30_1.diff (5.6 KB) - added by ctreleaven@… 17 months ago.
Needs testing
main_2014-01-26.log (27.2 KB) - added by christian-narr@… 15 months ago.

Change History

Changed 17 months ago by ctreleaven@…

comment:1 Changed 17 months ago by macsforever2000@…

  • Owner changed from macports-tickets@… to ecronin@…
  • Cc ecronin@… removed

comment:2 Changed 17 months ago by ctreleaven@…

Patch attached:

  • update to 0.9.0
  • add patch file for missing typedefs, fixes build with XCode 3.2.6
  • update other patch file to apply to current source
  • blacklist *clang* due to build failures (llvm-gcc4.2 is OK), fixes build with XCode 5.0.2
  • delete iguanaIR patch applied upstream and use configure.args-replace
  • gratuitous change to Notes

Now builds on 10.6.8/XCode 3.2.6 and 10.8.5/XCode 5.02, including IguanaIR variant. Needs live testing but I have no hardware to test anything other than UDP driver.

Changed 17 months ago by ctreleaven@…

Needs testing

Changed 15 months ago by christian-narr@…

comment:3 Changed 15 months ago by christian-narr@…

Hello,

i have the same problem on OSX 10.9.1 with Xcode Version 5.0.2 (5A3005) installed.

I have tried to apply your changes form patch-lirc_2013Nov30_1.diff. Not quite sure if I followed the correct procedure for patching, because i did it all manually.

After patching did a
port clean lirc
port install lirc

But still no luck, as shown in my log main_2014-01-26.log. Any advice for better testing would be welcome.

Kind regards

comment:4 follow-up: ↓ 5 Changed 15 months ago by ctreleaven@…

Your log indicates that it attempted to build with clang. Did you add the following line to the Portfile?

compiler.blacklist-append *clang*

MacPorts should fall back to llvm-gcc...which worked for me.

comment:5 in reply to: ↑ 4 Changed 15 months ago by christian-narr@…

Hello,

thanks for your quick response. When checking back, i missed exactly this line in the patches. Very sorry for that !

However In between i tried again with a fresh install of Macports and it worked fine now (still OS 10.9.1 and Xcode 5.0.2). So i guess something went wrong, when i tried to apply your patch manually.

Finally these were the steps with I managed the installation (may be not the best way):

sudo port install lirc
sudo port clean --all lirc

Then copied your patch to /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/sysutils/lirc and applied it

cd /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/sysutils/lirc
patch -p0 < patch-lirc_2013Nov30_1.diff

Finally tried to build and it worked fine !

sudo port patch lirc
sudo port configure lirc
sudo port build lirc
sudo port install lirc

So I could confirm it's working well with Xcode 5.0.2.

Again thank you very much for the Patch that made my day ! ;)

Last edited 15 months ago by christian-narr@… (previous) (diff)

comment:6 Changed 15 months ago by ecronin@…

  • Owner changed from ecronin@… to macports-tickets@…

I don't have mavericks installed yet so can't look into this, but blacklisting clang entirely should be a last resort. Has this at least been reported upstream? Reassigning since I can't test this (and don't have time at the moment to evaluate it). If someone else wants to commit this go for it.

ctreleaven: if you want maintainership please take it. I haven't used lirc regularly in a few years.

comment:7 Changed 15 months ago by christian-narr@…

  • Cc christian-narr@… added

Cc Me!

comment:8 Changed 15 months ago by ctreleaven@…

Hi Eric:

I tried to report upstream (https://sourceforge.net/apps/mantisbt/lirc/view.php?id=1) but I'm pretty sure now that is not the right spot. I'm on one of the Lirc mailing lists; I'll try to follow up.

I'll take over maintainership if you'd like. BTW, you made some changes to this port specifically for me 5 ro 6 years ago! I do appreciate the work you did.

Christian:

For my curiosity, how are you using Lirc?

Craig

comment:9 Changed 15 months ago by christian-narr@…

Hello Craig,

unfortunately i am not using any hardware devices for LIRCD on the Mac.

I just want to connect remotely to a LIRCD running on a Debian Box having a X10 radio signaled remote attached on USB. This is because the new Macbooks will not support the Apple Remote anymore :(

If it would help for testing, i could try attaching the X10 Receiver directly to the MAC and see if LIRCD could handle. But not quite sure if the required LIRC driver atilibusb is included in the macports build.

If I should investigate some more on this, please let me know.

Kind regards Christian

comment:10 Changed 13 months ago by me@…

  • Cc me@… added

Cc Me!

comment:11 Changed 13 months ago by me@…

I had the same problem on 10.9.2, and the patch fixed it.

comment:12 Changed 13 months ago by macsforever2000@…

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.