Opened 7 years ago

Closed 7 years ago

#41615 closed defect (worksforme)

Error: org.macports.destroot for port py27-pyqt4 returned: command execution failed

Reported by: ctu_gino@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: py27-pyqt4

Description

I've encountered this problem when I try to install py27-pyqt4. I searched Google but got nothing, I am wondering if anybody know how to solve this. Any help or clues are appreciated.

install_name_tool: object: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pyqt4/py27-pyqt4/work/destroot/opt/local/share/qt4/plugins/designer/libpy27qt4.dylib malformed object (unknown load command 4)
Command failed: install_name_tool -id libpy27qt4.dylib  /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pyqt4/py27-pyqt4/work/destroot/opt/local/share/qt4/plugins/designer/libpy27qt4.dylib
Exit code: 1
Error: org.macports.destroot for port py27-pyqt4 returned: command execution failed
Warning: targets not executed for py27-pyqt4: org.macports.activate org.macports.destroot org.macports.install
Please see the log file for port py27-pyqt4 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pyqt4/py27-pyqt4/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port py27-pyqt4 failed

Attachments (2)

main.log (1.3 MB) - added by ctu_gino@… 7 years ago.
main.log
Xcode.tiff (121.8 KB) - added by ctu_gino@… 7 years ago.
What Xcode->Preferrence...->Locations shows

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by ctu_gino@…

Attachment: main.log added

main.log

comment:1 Changed 7 years ago by ctu_gino@…

Cc: ctu_gino@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ctu_gino@… removed
Keywords: install_name_tool malformed object removed
Owner: changed from macports-tickets@… to michaelld@…

My first Google hit for this error was this page, which says what I anticipated: your install_name_tool command is probably too old for the version of OS X you're running. Reinstall it by reinstalling the Xcode command line tools.

comment:3 in reply to:  2 Changed 7 years ago by ctu_gino@…

Replying to ryandesign@…:

My first Google hit for this error was this page, which says what I anticipated: your install_name_tool command is probably too old for the version of OS X you're running. Reinstall it by reinstalling the Xcode command line tools.

Thanks, but it doesn't work. Actually I've tried this before.

My mac is running Mavericks and Xcode 5.0.2.
Xcode->Preference...->Location says "Command Line Tools: Xcode 5.0.2(5A3005)"
I also checked this:

pkgutil --file-info /usr/bin/install_name_tool

and it shows

volume: /
path: /usr/bin/install_name_tool

pkgid: com.apple.pkg.Essentials
pkg-version: 10.9.0.1.1.1306847324
install-time: 1383442489
uid: 0
gid: 0
mode: 755

I installed my Command Line Tool provided by Apple: https://developer.apple.com/downloads/index.action?name=for%20Xcode%20-

because I failed to run this

xcode-select --install

I got this message when I tried to use the command above: "Can't install the software because it is not currently available from the Software Update server." so I had to install Command Line Tool manually.

Last edited 7 years ago by ctu_gino@… (previous) (diff)

comment:4 Changed 7 years ago by michaelld (Michael Dickens)

If you start Xcode.app running, go into "Preferences...", click on "Downloads", is "Command Line Tools" checked? If not, then the correct CLTs are not yet installed. I just have Xcode install everything, without using the command-line utilities (e.g., xcode-select, xcodebuild, ...).

comment:5 in reply to:  4 Changed 7 years ago by ctu_gino@…

Replying to michaelld@…:

If you start Xcode.app running, go into "Preferences...", click on "Downloads", is "Command Line Tools" checked? If not, then the correct CLTs are not yet installed. I just have Xcode install everything, without using the command-line utilities (e.g., xcode-select, xcodebuild, ...).

Yes, it was checked. Anyway, I'm reinstalling Xcode to see if it works.

comment:6 in reply to:  4 Changed 7 years ago by ctu_gino@…

Replying to michaelld@…:

If you start Xcode.app running, go into "Preferences...", click on "Downloads", is "Command Line Tools" checked? If not, then the correct CLTs are not yet installed. I just have Xcode install everything, without using the command-line utilities (e.g., xcode-select, xcodebuild, ...).

unfortunately, reinstall Xcode and Macports do not help. I again encountered the problem above.

install_name_tool: object: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pyqt4/py27-pyqt4/work/destroot/opt/local/share/qt4/plugins/designer/libpy27qt4.dylib malformed object (unknown load command 4)
Command failed: install_name_tool -id libpy27qt4.dylib  /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pyqt4/py27-pyqt4/work/destroot/opt/local/share/qt4/plugins/designer/libpy27qt4.dylib
Exit code: 1
Error: org.macports.destroot for port py27-pyqt4 returned: command execution failed

Changed 7 years ago by ctu_gino@…

Attachment: Xcode.tiff added

What Xcode->Preferrence...->Locations shows

comment:7 in reply to:  4 Changed 7 years ago by ctu_gino@…

Replying to michaelld@…:

If you start Xcode.app running, go into "Preferences...", click on "Downloads", is "Command Line Tools" checked? If not, then the correct CLTs are not yet installed. I just have Xcode install everything, without using the command-line utilities (e.g., xcode-select, xcodebuild, ...).

Problem solved by install Port cctool, I guess there're some issues with new Xcode's Command Line Tools. Thank you all the same.

comment:8 Changed 7 years ago by michaelld (Michael Dickens)

Resolution: worksforme
Status: newclosed

Interesting; I'm glad it working now for you, no matter how strange the reason,

Note: See TracTickets for help on using tickets.