Opened 7 years ago

Closed 21 months ago

#41709 closed defect (worksforme)

Mac OS X- loading two sets of Qt binaries into the same process

Reported by: gtmdhl@… Owned by: jgosmann (Jan Gosmann)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cgilles (HumanDynamo), cooljeanius (Eric Gallager), ryandesign (Ryan Schmidt), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: digikam

Description (last modified by ryandesign (Ryan Schmidt))

I have followed the routine of installing Digikam on Mac OS 10.9 as suggested by Gilles Caulie. I continue to experience an unstable program which crashes easily upon almost any simple menue command. Perhaps the followng error message is the cause.

"On Mac OS X, you might be loading two sets of Qt binaries into the same process. Check that all plugins are compiled against the right Qt binaries. Export DYLD_PRINT_LIBRARIES=1 and check that only one set of binaries are being loaded. QObject::moveToThread: Current thread (0x7fdce9c028e0) is not the object's thread (0x7fdce9de92a0). Cannot move to target thread (0x7fdce9c028e0)"

I have attempted to research the issue on Macports through the ticket system. I found Ticket #19217 which addresses some of this issue but I do not see any recommendations as to a process to resolve the issue. Regarding the reference of DYLD , "Export DYLD_PRINT_LIBRARIES=1 and check that only one set of binaries are being loaded". My search of the MacPorts Ticket issues found little of the DYLD issue and did not suggest how to use the libraries.

Any assistance or suggestions as to what I might do to correct these issues will be appreciated. David Lyon

Change History (9)

comment:1 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: two sets of Qt binaries removed
Owner: changed from macports-tickets@… to jan@…

Regarding the message you quoted, do you have any reason to believe that you have multiple sets of Qt binaries? Have you installed a copy of Qt outside of MacPorts? What happens if you run DYLD_PRINT_LIBRARIES=1 digikam -- does it show multiple different sets of Qt libraries being used?

comment:3 in reply to:  2 ; Changed 7 years ago by gtmdhl@…

Replying to ryandesign@…:

Regarding the message you quoted, do you have any reason to believe that you have multiple sets of Qt binaries? Have you installed a copy of Qt outside of MacPorts? What happens if you run DYLD_PRINT_LIBRARIES=1 digikam -- does it show multiple different sets of Qt libraries being used?

I have attempted to run the inquiry but perhaps my ignorance of the nomenlature is a problem.

bash-3.2$ DYLD_PRINT_LIBRARIES=1digikam
bash-3.2$ 'DYLD_PRINT_LIBRARIES=1 digikam'
bash: DYLD_PRINT_LIBRARIES=1 digikam: command not found
bash-3.2$ DYLD_PRINT_LIBRARIES=1 digikam
bash: digikam: command not found
bash-3.2$ 

I get no results with what I have tried.
Please advise.
Thanks,
David

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 Changed 7 years ago by cgilles (HumanDynamo)

David,

I see the smae problem on my macbook after to update on Maverick.

All Qt applications compile fine (digiKam & co) but at run time, i see the same error than you.

I uninstalled all macports and reinstalled all libraries and programs WITHOUT "+debug" option through Macports

Sound like there is a conflict at linking that mix debug and not debug objects.

Gilles Caulier

comment:5 in reply to:  3 ; Changed 7 years ago by ryandesign (Ryan Schmidt)

Replying to gtmdhl@…:

bash-3.2$ DYLD_PRINT_LIBRARIES=1 digikam
bash: digikam: command not found

How does one usually start digikam? I thought the digikam port would install a digikam executable, but maybe not. I have not been able to install digikam on my own machine yet to verify.

comment:6 in reply to:  5 ; Changed 7 years ago by ryandesign (Ryan Schmidt)

Ok, I've managed to install digikam, and I see now it's an application bundle. So try:

DYLD_PRINT_LIBRARIES=1 /Applications/MacPorts/KDE4/digikam.app/Contents/MacOS/digikam

comment:7 in reply to:  6 Changed 7 years ago by gtmdhl@…

Replying to ryandesign@…:

Ok, I've managed to install digikam, and I see now it's an application bundle. So try:

DYLD_PRINT_LIBRARIES=1 /Applications/MacPorts/KDE4/digikam.app/Contents/MacOS/digikam

Upon running the suggested sequence there are no duplicate libraries. However since the problem was created, I have uninstalled digikam and MacPorts, cleaned and reinstalled MacPorts and digikam. Thanks for your support. David

comment:8 Changed 21 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:9 Changed 21 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: newclosed

Since the reporter says that things are working, and Qt has been drastically changed in the intervening years, I think this ticket can safely be closed.

Note: See TracTickets for help on using tickets.