Opened 7 years ago

Closed 4 years ago

#41825 closed defect (fixed)

openexr: configure failure on Mavericks

Reported by: gnupost@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: kurthindenburg (Kurt Hindenburg)
Port: openexr

Description

Hello All!

While trying to install povray in Mavericks, openexr package failed to configure. This is the main.log

version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Executing org.macports.main (openexr)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (openexr)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (openexr)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (openexr)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (openexr)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (openexr)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:configure configure phase started at Sun Dec 15 12:24:33 WET 2013
:notice:configure --->  Configuring openexr
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing org.macports.configure (openexr)
:debug:configure Environment: CPATH='/opt/local/include' CFLAGS='-pipe -Os -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -Os -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.9' CXX='/usr/bin/clang++' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/work/.CC_PRINT_OPTIONS' F90FLAGS='-pipe -Os -m64' LDFLAGS='-L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64' FCFLAGS='-pipe -Os -m64' OBJC='/usr/bin/clang' OBJCXX='/usr/bin/clang++' INSTALL='/usr/bin/install -c' OBJCFLAGS='-pipe -Os -arch x86_64' OBJCXXFLAGS='-pipe -Os -arch x86_64' FFLAGS='-pipe -Os -m64' CC_PRINT_OPTIONS='YES' CC='/usr/bin/clang'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/work/openexr-1.7.0" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --infodir=/opt/local/share/info'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/work/openexr-1.7.0" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --infodir=/opt/local/share/info 
:info:configure checking build system type... i686-apple-darwin13.0.0
:info:configure checking host system type... i686-apple-darwin13.0.0
:info:configure checking for a BSD-compatible install... /usr/bin/install -c
:info:configure checking whether build environment is sane... yes
:info:configure checking for gawk... no
:info:configure checking for mawk... no
:info:configure checking for nawk... no
:info:configure checking for awk... awk
:info:configure checking whether make sets $(MAKE)... yes
:info:configure checking whether to enable maintainer-specific portions of Makefiles... no
:info:configure checking for C++ compiler default output file name... a.out
:info:configure checking whether the C++ compiler works... yes
:info:configure checking whether we are cross compiling... no
:info:configure checking for suffix of executables... 
:info:configure checking for suffix of object files... o
:info:configure checking whether we are using the GNU C++ compiler... yes
:info:configure checking whether /usr/bin/clang++ accepts -g... yes
:info:configure checking for style of include used by make... GNU
:info:configure checking dependency style of /usr/bin/clang++... gcc3
:info:configure checking for a BSD-compatible install... /usr/bin/install -c
:info:configure checking for gcc... /usr/bin/clang
:info:configure checking whether we are using the GNU C compiler... yes
:info:configure checking whether /usr/bin/clang accepts -g... yes
:info:configure checking for /usr/bin/clang option to accept ANSI C... none needed
:info:configure checking dependency style of /usr/bin/clang... gcc3
:info:configure checking whether ln -s works... yes
:info:configure checking for a sed that does not truncate output... /opt/local/bin/gsed
:info:configure checking for egrep... grep -E
:info:configure checking for ld used by /usr/bin/clang... /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld
:info:configure checking if the linker (/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld) is GNU ld... no
:info:configure checking for /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld option to reload object files... -r
:info:configure checking for BSD-compatible nm... /opt/local/bin/nm
:info:configure checking how to recognise dependent libraries... pass_all
:info:configure checking how to run the C preprocessor... /usr/bin/clang -E
:info:configure checking for ANSI C header files... yes
:info:configure checking for sys/types.h... yes
:info:configure checking for sys/stat.h... yes
:info:configure checking for stdlib.h... yes
:info:configure checking for string.h... yes
:info:configure checking for memory.h... yes
:info:configure checking for strings.h... yes
:info:configure checking for inttypes.h... yes
:info:configure checking for stdint.h... yes
:info:configure checking for unistd.h... yes
:info:configure checking dlfcn.h usability... yes
:info:configure checking dlfcn.h presence... yes
:info:configure checking for dlfcn.h... yes
:info:configure checking how to run the C++ preprocessor... /usr/bin/clang++ -E
:info:configure checking for g77... no
:info:configure checking for f77... no
:info:configure checking for xlf... no
:info:configure checking for frt... no
:info:configure checking for pgf77... no
:info:configure checking for fort77... no
:info:configure checking for fl32... no
:info:configure checking for af77... no
:info:configure checking for f90... no
:info:configure checking for xlf90... no
:info:configure checking for pgf90... no
:info:configure checking for epcf90... no
:info:configure checking for f95... no
:info:configure checking for fort... no
:info:configure checking for xlf95... no
:info:configure checking for ifc... no
:info:configure checking for efc... no
:info:configure checking for pgf95... no
:info:configure checking for lf95... no
:info:configure checking for gfortran... no
:info:configure checking whether we are using the GNU Fortran 77 compiler... no
:info:configure checking whether  accepts -g... no
:info:configure checking the maximum length of command line arguments... 196608
:info:configure checking command to parse /opt/local/bin/nm output from /usr/bin/clang object... ok
:info:configure checking for objdir... .libs
:info:configure checking for ar... ar
:info:configure checking for ranlib... ranlib
:info:configure checking for strip... strip
:info:configure checking if /usr/bin/clang supports -fno-rtti -fno-exceptions... yes
:info:configure checking for /usr/bin/clang option to produce PIC... -fno-common
:info:configure checking if /usr/bin/clang PIC flag -fno-common works... yes
:info:configure checking if /usr/bin/clang static flag -static works... no
:info:configure checking if /usr/bin/clang supports -c -o file.o... yes
:info:configure checking whether the /usr/bin/clang linker (/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld) supports shared libraries... yes
:info:configure checking dynamic linker characteristics... darwin13.0.0 dyld
:info:configure checking how to hardcode library paths into programs... immediate
:info:configure checking whether stripping libraries is possible... yes
:info:configure checking if libtool supports shared libraries... yes
:info:configure checking whether to build shared libraries... yes
:info:configure checking whether to build static libraries... yes
:info:configure configure: creating libtool
:info:configure appending configuration tag "CXX" to libtool
:info:configure checking for ld used by /usr/bin/clang++... /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld
:info:configure checking if the linker (/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld) is GNU ld... no
:info:configure checking whether the /usr/bin/clang++ linker (/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld) supports shared libraries... yes
:info:configure checking for /usr/bin/clang++ option to produce PIC... -fno-common
:info:configure checking if /usr/bin/clang++ PIC flag -fno-common works... yes
:info:configure checking if /usr/bin/clang++ static flag -static works... no
:info:configure checking if /usr/bin/clang++ supports -c -o file.o... yes
:info:configure checking whether the /usr/bin/clang++ linker (/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld) supports shared libraries... yes
:info:configure checking dynamic linker characteristics... darwin13.0.0 dyld
:info:configure checking how to hardcode library paths into programs... immediate
:info:configure appending configuration tag "F77" to libtool
:info:configure checking whether make sets $(MAKE)... (cached) yes
:info:configure test_prefix = NONE
:info:configure checking for pkg-config... /opt/local/bin/pkg-config
:info:configure using pkg-config to set ILMBASE_CXXFLAGS and ILMBASE_LDFLAGS:
:info:configure     ILMBASE_CXXFLAGS = -D_THREAD_SAFE -I/usr/local/include/OpenEXR 
:info:configure     ILMBASE_LDFLAGS = -L/usr/local/lib 
:info:configure     ILMBASE_LIBS = -L/usr/local/lib -lImath -lHalf -lIex -lIexMath -lIlmThread 
:info:configure checking for IlmBase... no
:info:configure *** Could not run the IlmBase test program, checking why...
:info:configure *** The IlmBase test program could be compiled, but could not be dynamically.
:info:configure *** or statically linked.
:info:configure ***
:info:configure *** Make sure the LDFLAGS points to the location of the IlmBase library.
:info:configure *** (e.g. -L/usr/local/lib).
:info:configure *** If the run-time linker is not finding IlmBase, you'll need to set your
:info:configure *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
:info:configure *** to the installed location  Also, make sure you have run ldconfig if that
:info:configure *** is required on your system.
:info:configure ***
:info:configure *** Flags used by the test:
:info:configure ***     cflags: -pipe -Os -arch x86_64 -D_THREAD_SAFE -I/usr/local/include/OpenEXR  
:info:configure ***     ldflags: -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64 -L/usr/local/lib 
:info:configure ***
:info:configure *** You can also run configure with --disable-ilmbasetest to skip this test.
:info:configure configure: error: Could not compile IlmBase test program.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/work/openexr-1.7.0" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --infodir=/opt/local/share/info 
:info:configure Exit code: 1
:error:configure Failed to configure openexr, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/work/openexr-1.7.0/config.log
:error:configure org.macports.configure for port openexr returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for openexr: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:configure Failed to install openexr
:debug:configure couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
:notice:configure Please see the log file for port openexr for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/main.log

Thanks for your wonderful job! Gonçalo

Change History (6)

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Keywords: openexr removed
Owner: changed from macports-tickets@… to blair@…
Summary: Failed to configure openexr in mavericksopenexr: configure failure on Mavericks

comment:2 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:3 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Updating both ilmbase and openexr to 2.1.0 and removing the patches and post-configure - they both appear to build and install correctly on Mavericks.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Those updates are requested in #44619 and #44620 respectively.

comment:5 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: changed from blair@… to mcalhoun@…
Status: newassigned

comment:6 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed

One of the comments indicated that updating openexr would fix the problem.
This was accomplished in r148894.
Please feel free to reopen if the problem is not, in fact, fixed.

Note: See TracTickets for help on using tickets.