Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#41890 closed update (fixed)

dar: update to 2.4.11 and fix build on Mavericks

Reported by: jgosmann (Jan Gosmann) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: haspatch Cc:
Port: dar

Description (last modified by ryandesign (Ryan Schmidt))

I fixed the compilation with clang for the dar port and updated it to the current stable version.

The compilation problems have been reported upstream and a patch has been submitted: https://sourceforge.net/p/dar/patches/32/
The same holds for the Makefile.in patch: https://sourceforge.net/p/dar/patches/33/

Attachments (3)

Portfile-dar.diff (945 bytes) - added by jgosmann (Jan Gosmann) 6 years ago.
Patchfile for the portfile.
patch-clang-compatibility.diff (7.3 KB) - added by jgosmann (Jan Gosmann) 6 years ago.
Required patchfile for compilation with clang.
patch-doc-Makefile.in.diff (427 bytes) - added by jgosmann (Jan Gosmann) 6 years ago.
Patchfile for Makefile.in

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by jgosmann (Jan Gosmann)

Attachment: Portfile-dar.diff added

Patchfile for the portfile.

Changed 6 years ago by jgosmann (Jan Gosmann)

Required patchfile for compilation with clang.

Changed 6 years ago by jgosmann (Jan Gosmann)

Attachment: patch-doc-Makefile.in.diff added

Patchfile for Makefile.in

comment:1 Changed 6 years ago by mf2k (Frank Schima)

I noticed a few issues:

  • The revision needs to be deleted as with all version upgrades.
  • A sha256 checksum should be added per Macports standards.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Resolution: fixed
Status: assignedclosed
Summary: Compilation fix and update of dar portdar: update to 2.4.11 and fix build on Mavericks

Committed in r115110. I also added the ticket URLs to the patchfiles, and added dependencies on libgcrypt and lzo2 because they did get linked to.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

It failed to build on the Snow Leopard buildslave (which uses gcc-4.2; the newer buildslaves use clang):

mask_list.hpp:80: error: invalid pure specifier (only `= 0' is allowed) before ‘;’ token
mask_list.hpp:80: error: initializer specified for non-virtual method ‘libdar::mask_list::my_char::my_char()’

I could reproduce this on Mavericks by changing the compiler to either macports-llvm-gcc-4.2 or apple-gcc-4.2:

sudo port install llvm-gcc42
sudo port install dar configure.compiler=macports-llvm-gcc-4.2
sudo port install apple-gcc42
sudo port install dar configure.compiler=apple-gcc-4.2

In r115111 I changed the port to only use the clang compatibility patch when the compiler is clang, but a better patch that works regardless of compiler is needed.

comment:5 Changed 6 years ago by jgosmann (Jan Gosmann)

A better patch is supposed to be included in the upcoming 2.4.13 release of dar making the current patch obsolete.

Note: See TracTickets for help on using tickets.