Opened 9 years ago

Closed 8 years ago

#42069 closed enhancement (fixed)

py-libxml2 @2.9.1: add python32 and python33 subports

Reported by: zpeeters@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: petrrr
Port: py-libxml2

Description (last modified by ryandesign (Ryan Schmidt))

Since version 2.9.1 libxml2 supports Python 3.X. I have tested python 3.2 and 3.3 (and 2.7). Python 3.1 and 3.4 may also work. All tests in ${worksrcpath}/tests return "OK". libxml2mod imports without error (i.e. I cannot reproduce ticket #39579).

In addition, changed url for master_sites and livecheck.url.

Attachments (3)

Portfile.diff (1.3 KB) - added by zpeeters@… 9 years ago.
patch-setup.py.diff (4.7 KB) - added by zpeeters@… 9 years ago.
This file replaces the current patch-setup.py.diff and includes those changes.
patch-drv_libxml2.py.diff (851 bytes) - added by zpeeters@… 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by zpeeters@…

Attachment: Portfile.diff added

Changed 9 years ago by zpeeters@…

Attachment: patch-setup.py.diff added

This file replaces the current patch-setup.py.diff and includes those changes.

Changed 9 years ago by zpeeters@…

Attachment: patch-drv_libxml2.py.diff added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: sfiera@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to sfiera@…
Type: defectenhancement

comment:2 Changed 9 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:3 Changed 8 years ago by mf2k (Frank Schima)

Cc: mcalhoun@… removed
Owner: changed from sfiera@… to mcalhoun@…
Version: 2.2.1

Assigning to current maintainer. See #44785.

Last edited 8 years ago by mf2k (Frank Schima) (previous) (diff)

comment:4 Changed 8 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:5 Changed 8 years ago by petrrr

Cc: Peter.Danecek@… removed

comment:6 Changed 8 years ago by petrrr

Marcus, could look at this one?

comment:7 Changed 8 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

Some of the proposed changes seem to have been rendered obsolete by r127065, r127066, r127068, and r127108.
Support for older versions of python seems to be ending (see Retiring Python 2.4 and 2.5) in MacPorts, so I removed Python 3.2 and 3.3 support from the proposed change.

Support for Python 3.4 was added in r127383.
Thanks for the patch.

Note: See TracTickets for help on using tickets.