Opened 7 years ago

Closed 6 years ago

#42357 closed defect (fixed)

avrdude won't compile

Reported by: gustaf.borgstrom@… Owned by: bsd@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: g5pw (Aljaž Srebrnič)
Port: avrdude

Description

Several compilation errors shows up and aborts the compilation of avrdude, i.e. running:

sudo port install avrdude

Log file is included.

Attachments (1)

main.log (48.4 KB) - added by gustaf.borgstrom@… 7 years ago.
Log file ouput

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by gustaf.borgstrom@…

Attachment: main.log added

Log file ouput

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Keywords: avrdude 6.0.1 removed
Owner: changed from macports-tickets@… to bsd@…

In the future, please Cc the port maintainers (port info --maintainers avrdude).

comment:2 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Does the new version (6.1) compile correctly now?

comment:3 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Cc: g5pw@… added

Cc Me!

comment:4 Changed 6 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed

From the log file, it looks like libelf was not found. This should be fixed in r120473 with the inclusion of the libelf dependency, so I'll close this ticket as fixed. Feel free to reopen it if the issue still exists.

Note: See TracTickets for help on using tickets.