Opened 7 years ago

Closed 3 years ago

#42555 closed defect (worksforme)

Librecad install fails, cannot find boost.

Reported by: watsodw Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: librecad@…, dongxuli2011@…, anddam (Andrea D'Amore)
Port: librecad

Description

See log.

Attachments (2)

main.log (83.9 KB) - added by watsodw 7 years ago.
and.damore-main.log (1.7 MB) - added by anddam (Andrea D'Amore) 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by watsodw

Attachment: main.log added

comment:1 Changed 7 years ago by librecad@…

David,

can you try this?

sudo port -f uninstall boost
sudo port install boost

I am almos thinking something happened to you boost installation that should be available in /opt/local/include/boost

the above two commands would try to remove and install boost.

Last edited 4 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 5 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Cc Me!

comment:3 Changed 5 years ago by anddam (Andrea D'Amore)

I'm hitting the same issue on a fresh new install on 10.11, LibreCAD is now @2.0.8_0 and I do have boost and muparser (see #43276) installed and active.

I see at first

	cd src/ && /opt/local/libexec/qt4/bin/qmake /opt/local/var/macports/build/_opt_macports_trunk_dports_cad_LibreCAD/LibreCAD/work/LibreCAD-2.0.8/librecad/src/sr Project MESSAGE: We will be using CPP11 features
	Project MESSAGE: Found Boost in /opt/local
	Project MESSAGE: Using Boost includes from /opt/local/include
	Project MESSAGE: Using bundled muparser

but then later on

	Project MESSAGE: We will be using CPP11 features
	Project ERROR: Boost installation not found.
	Project ERROR: does not contain a Boost installation
	Project MESSAGE: Using bundled muparser
	Project MESSAGE: Emulating C99 math features.

I'm attaching reformatted main.log since the qmake output is not producing newlines.

As further note even if there's the Boost error the resulting application bundle correctly works, see #50119.

Last edited 5 years ago by anddam (Andrea D'Amore) (previous) (diff)

Changed 5 years ago by anddam (Andrea D'Amore)

Attachment: and.damore-main.log added

comment:4 Changed 3 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed

LibreCAD has been updated to version 2.1.3. Please re-open and attach a new main.log file if this is still an issue.

Note: See TracTickets for help on using tickets.