Opened 8 years ago

Closed 6 years ago

#42732 closed defect (worksforme)

mpfr @3.1.1-p2: test suite fails on x86_64 Snow Leopard (when run with `port test gmp mpfr libmpc`)

Reported by: cooljeanius (Eric Gallager) Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: mww@…
Port: mpfr

Description

I was trying to track down the causes for #40548, so I re-ran the testsuite for gmp and mpfr as upstream instructed (and libmpc, too, but it failed on mpfr before it got to that), and it ran into a bunch of "Illegal instruction" errors. This could have been caught earlier if testsuites could run automatically as part of the normal install process as per #42731. Anyways attaching my log...

(mpfr is nomaintainer, but I am cc-ing mww because it is a sub-issue of the libgcc issue I mentioned previously, and mww is the maintainer for libgcc)

Attachments (2)

main.log (1.2 MB) - added by cooljeanius (Eric Gallager) 8 years ago.
main.log for mpfr's failed testsuite
mpfr_crashes.zip (130.2 KB) - added by cooljeanius (Eric Gallager) 8 years ago.
zip archive of crash reports generated during mpfr's test suite - there should be 58 of them.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by cooljeanius (Eric Gallager)

Attachment: main.log added

main.log for mpfr's failed testsuite

comment:1 Changed 8 years ago by cooljeanius (Eric Gallager)

(and libmpc, too, but it failed on mpfr before it got to that)

Turns out that libmpc has its own failures as well, so that is #42733

Changed 8 years ago by cooljeanius (Eric Gallager)

Attachment: mpfr_crashes.zip added

zip archive of crash reports generated during mpfr's test suite - there should be 58 of them.

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to larryv@…

comment:3 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: worksforme
Status: newclosed

I cannot reproduce this with mpfr @3.1.3_0 on my Snow Leopard VM. Feel free to reopen if you still encounter this.

Note: See TracTickets for help on using tickets.