Opened 15 years ago

Closed 15 years ago

#4277 closed defect (fixed)

graphviz +nox11 or +quartz still tries to build xfree86

Reported by: clkao@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

clkao:~/work/svk clkao$ sudo /opt/local/bin/port -v clean graphviz +nox11 ---> Cleaning graphviz ---> Removing workpath for graphviz clkao:~/work/svk clkao$ sudo /opt/local/bin/port -v install graphviz +nox11 ---> Fetching XFree86

It's likely caused by the variant not being propogate to dependencies like freetype, so it still tries to build xfree86.

Change History (3)

comment:1 Changed 15 years ago by clkao@…

+nox11 +notk does the trick. perhaps +nox11 should imply +notk.

comment:2 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to gwright@…

please assign to maintainer;

comment:3 Changed 15 years ago by gwright@…

Resolution: fixed
Status: newclosed

X11 was being fetched to satisfy the tk dependency. The nox11 variant now turns off tk as well.

The quartz variant still builds x11. This is the correct behavior: the quartz variant does not provide a full replacement for the x11 functionality. If you want _only_ quartz and are willing to live without the x11 based programs, specify both +quartz and +nox11.

-Greg

Note: See TracTickets for help on using tickets.