Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#42866 closed defect (fixed)

inkscape@0.48.4_28 fails to build using Xcode 5.1

Reported by: mkae (Marko Käning) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: su-v, macports@…, JanOppolzer (Jan Oppolzer), hapaguy (Brian Kurt Fujikawa), jwhowse4, macports@…, gallafent, SickTeddyBear, jjstickel (Jonathan Stickel), Dmole (Tim), neo954 (Gᴏɴɢ Jie), whcordis@…, ktaylor1024@…
Port: inkscape

Description

:info:build In file included from ./2geom/d2.h:429:
:info:build ./2geom/rect.h:218:49: error: invalid operands to binary expression ('const Geom::OptRect' and 'int')
:info:build     inline bool isEmpty() const { return (*this == false); };
:info:build                                           ~~~~~ ^  ~~~~~
:info:build /opt/local/include/boost/optional/optional.hpp:859:6: note: candidate function [with T = Geom::D2<Geom::Interval>] not viable: no known conversion from 'bool' to 'none_t' (aka 'int boost::detail::none_helper::*') for 2nd argument
.
.
.
:info:build connector-context.cpp:1289:17: error: no matching function for call to 'sp_object_setAttribute'
:info:build                 sp_object_setAttribute(cc->clickeditem,
:info:build                 ^~~~~~~~~~~~~~~~~~~~~~
:info:build ./sp-object.h:573:6: note: candidate function not viable: no known conversion from 'bool' to 'SPException *' for 4th argument
:info:build void sp_object_setAttribute(SPObject *object, gchar const *key, gchar const *value, SPException *ex);
:info:build      ^

Attachments (2)

inkscape_Portfile.diff (588 bytes) - added by jjstickel (Jonathan Stickel) 6 years ago.
10019_10017.diff (7.3 KB) - added by jjstickel (Jonathan Stickel) 6 years ago.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 6 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

comment:2 Changed 6 years ago by mkae (Marko Käning)

Is this ticket invalid for some reason, or what's the resolution?

comment:3 Changed 6 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: closedreopened

I clicked the wrong button, sorry. Are you using Xcode 5.1?

comment:4 Changed 6 years ago by dbevans (David B. Evans)

Status: reopenednew

comment:5 Changed 6 years ago by dbevans (David B. Evans)

Status: newassigned

comment:6 Changed 6 years ago by mkae (Marko Käning)

This is my setup

Version:	5.1 (5B130a)
  Location:	/Applications/Xcode.app
  Applications:
  Xcode:	5.1 (5084)
  Instruments:	5.1 (55044)
  SDKs:
  OS X:
  10,8:	(12F37)
  10,9:	(13C64)
  iOS:
  7,1:	(11D167)
  iOS Simulator:
  7,1:	(11D167)

comment:7 Changed 6 years ago by dbevans (David B. Evans)

I asked because it's reproducible on ML with Xcode 5.1 as well. I was just updating the port and will address this as part of the update. Already fixed a similar error with inkscape-devel (not committed as yet). Thanks for the report.

comment:8 Changed 6 years ago by mkae (Marko Käning)

Oh great. Thanks for the fast response. :)

comment:9 Changed 6 years ago by markt1964@…

Any ETA on how soon a fix for this will be out? I only ask since one of the above comments says that a similar issue was fixed already, but not yet committed.

comment:10 Changed 6 years ago by dbevans (David B. Evans)

Should have inkscape-devel committed in the next hour or so. Doing final test builds for the +gtk3 +svg2 variants now. If you are an inkscape user, I would suggest this over the inkscape port as the latter is a bit long in the tooth and all the new stuff is in the devel version. Upstream has gone into code 'chill' mode (pre-release bug fixing) for the next release which will be 0.91 rather than 0.48 (meant to convey closeness to 1.0). So its pretty stable and if you find any bugs this is a good time to report them before the final release.

I should have inkscape ready this evening or tomorrow at the latest. Adding additional patches backported from trunk plus the build problem reported here.

comment:11 Changed 6 years ago by su-v

Cc: suv-sf@… added

Cc Me!

comment:12 Changed 6 years ago by dbevans (David B. Evans)

Keywords: xcode51 added; Mavericks removed
Summary: inkscape@0.48.4_27 fails to build on 10.9.2 Mavericksinkscape@0.48.4_28 fails to build using Xcode 5.1

I've committed a new version of inkscape that is update to the latest upstream patch level ( bzr 10017) in r117894 but the problem reported here remains. I've confirmed that the problem occurs with Xcode 5.1 on either 10.8 or 10.9 -- build is successful using Xcode 5.0.2 on either platform.

The problem is also restricted to inkscape 0.48.4 + patches and does not effect upstream trunk (inkscape-devel) which was recently updated to fix another (very minor) Xcode 5.1 problem. The problem appears to be related to code in the old version of lib2geom used in inkscape 0.48.4. Again the version in trunk and the stand-alone lib2geom build without problems.

Reporting this upstream for resolution.

comment:13 Changed 6 years ago by dbevans (David B. Evans)

comment:14 Changed 6 years ago by mkae (Marko Käning)

I could successfully install inkscape-devel on 10.9.2. Thanks for taking care of this!

comment:15 Changed 6 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:16 Changed 6 years ago by JanOppolzer (Jan Oppolzer)

Cc: jan.oppolzer@… added

Cc Me!

comment:17 Changed 6 years ago by alexandre@…

Cc: alexandre@… added

Cc Me!

comment:18 Changed 6 years ago by hapaguy (Brian Kurt Fujikawa)

Cc: brian.fujikawa@… added

Cc Me!

comment:19 Changed 6 years ago by jwhowse4

Cc: jwhowse4@… added

Cc Me!

comment:20 Changed 6 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:21 Changed 6 years ago by gallafent

Cc: william@… added

Cc Me!

comment:22 Changed 6 years ago by SickTeddyBear

Cc: amcgee@… added

Cc Me!

comment:23 Changed 6 years ago by jjstickel (Jonathan Stickel)

Cc: jjstickel@… added

Cc Me!

comment:24 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: elatllat@… added
Keywords: xcode51 removed

Has duplicate #42981.

comment:25 Changed 6 years ago by neo954 (Gᴏɴɢ Jie)

Cc: gongjie.jie@… added

Cc Me!

comment:26 Changed 6 years ago by whcordis@…

Cc: whcordis@… added

Cc Me!

Changed 6 years ago by jjstickel (Jonathan Stickel)

Attachment: inkscape_Portfile.diff added

Changed 6 years ago by jjstickel (Jonathan Stickel)

Attachment: 10019_10017.diff added

comment:27 in reply to:  13 Changed 6 years ago by jjstickel (Jonathan Stickel)

Replying to devans@…:

Upstream bug report is https://bugs.launchpad.net/inkscape/+bug/1293169

A patch is available upstream. Including the patch resolved the problem for me -- see attached files.

comment:28 Changed 6 years ago by ktaylor1024@…

Cc: ktaylor1024@… added

Cc Me!

comment:29 Changed 6 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

Updated to include upstream fix in r118178.

comment:30 Changed 6 years ago by alexandre@…

Cc: alexandre@… removed

Cc Me!

Note: See TracTickets for help on using tickets.