Opened 7 years ago

Closed 7 years ago

#42912 closed update (wontfix)

swi-prolog @6.6.3: update to 6.6.3

Reported by: pmoura (Paulo Moura) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: haspatch maintainer Cc: J.Wielemaker@…
Port: swi-prolog

Description

Update swi-prolog portfile for the latest release.

Attachments (2)

Portfile-swi-prolog.diff (682 bytes) - added by pmoura (Paulo Moura) 7 years ago.
main.log (152.1 KB) - added by ci42 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by pmoura (Paulo Moura)

Attachment: Portfile-swi-prolog.diff added

Changed 7 years ago by ci42

Attachment: main.log added

comment:1 Changed 7 years ago by ci42

Thanks for the patch, but it didn't build on 10.7.5. See the attached log file.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

It does build for me on 10.9.2.

I notice the problem occurs in the section "Making XPCE 6.6.66, July 2009". In your Lion log, it has:

:info:build c89 -I. -DHAVE_CONFIG_H -o xpce-copy /opt/local/var/macports/build/_Users_ci_devel_repos_macports_trunk_dports_lang_swi-prolog/swi-prolog/work/pl-6.6.3/packages/xpce/src/xpce-copy.c
:info:build i686-apple-darwin11-llvm-gcc-4.2: HAVE_CONFIG_H: No such file or directory

In my Mavericks log, it has:

:info:build cc -I. -DHAVE_CONFIG_H -o xpce-copy /opt/local/var/macports/build/_Users_rschmidt_macports_dports_lang_swi-prolog/swi-prolog/work/pl-6.6.3/packages/xpce/src/xpce-copy.c

Either way, "c89" and "cc" are not UsingTheRightCompiler.

comment:3 Changed 7 years ago by ci42

Resolution: wontfix
Status: newclosed

Superseded by #42952.

Note: See TracTickets for help on using tickets.