Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#4297 closed defect (fixed)

BUG: mutt doesn't compile with Xcode 2.1 on OS X 10.4.2

Reported by: satadru@… Owned by: yeled@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: brent@…, yeled@…, jay@…
Port:

Description

sudo port install mutt fails with this error:

gcc -DPKGDATADIR=\"/opt/local/share/mutt\" -DSYSCONFDIR=\"/opt/local/etc\" -DBINDIR=\"/opt/local/bin\" -DMUTTLOCALEDIR=\"/opt/local/share/locale\" -DHAVE_CONFIG_H=1 -I. -I. -Iintl -I/opt/local/include -I./intl -I/opt/local/include -g -O2 -c addrbook.c In file included from mutt_menu.h:23,

from addrbook.c:20:

keymap.h:83: error: array type has incomplete element type make[2]: * [addrbook.o] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive-am] Error 2

Attachments (1)

typescript.nntp (27.1 KB) - added by brent@… 15 years ago.
"port build" output

Download all attachments as: .zip

Change History (16)

comment:1 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to eric@…

Assigning to maintainer.

comment:2 Changed 15 years ago by yeled@…

Status: newassigned

I can't reproduce this. Can you give more information?

comment:3 Changed 15 years ago by satadru@…

(In reply to comment #2)

I can't reproduce this. Can you give more information?

uname -a gives:

Darwin Mac-Mini.local 8.2.0 Darwin Kernel Version 8.2.0: Fri Jun 24 17:46:54 PDT 2005; root:xnu-792.2.4.obj~3/RELEASE_PPC Power Macintosh powerpc

gcc --version: powerpc-apple-darwin8-gcc-4.0.0 (GCC) 4.0.0 (Apple Computer, Inc. build 5026)

$sudo /opt/local/bin/port install mutt ---> Building mutt with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_mail_mutt/work/mutt-1.4.2.1" && make all" returned error 2 Command output: cd .. \

&& CONFIG_FILES=doc/Makefile CONFIG_HEADERS= /bin/sh ./config.status

config.status: creating doc/Makefile config.status: executing default-1 commands config.status: executing default-2 commands gcc -E -I. -I.. -I/opt/local/include -I.. -DSYSCONFDIR=\"\" -DBINDIR=\"/opt/local/bin\" -DHAVE_CONFIG_H=1 -I/opt/local/include -I../intl -D_MAKEDOC -C ../init.h | ../makedoc -m | \

cat ./muttrc.man.head - ./muttrc.man.tail\

muttrc.man

touch stamp-doc-man

test -f manual.html test -f manual.txt
make manual.html cp ./manual*.html ./
make manual.txt cp ./manual.txt ./

Making all in contrib cd .. \

&& CONFIG_FILES=contrib/Makefile CONFIG_HEADERS= /bin/sh ./config.status

config.status: creating contrib/Makefile config.status: executing default-1 commands config.status: executing default-2 commands make[2]: Nothing to be done for `all'. cd . \

&& CONFIG_FILES=Makefile CONFIG_HEADERS= /bin/sh ./config.status

config.status: creating Makefile config.status: executing default-1 commands config.status: executing default-2 commands gcc -DPKGDATADIR=\"/opt/local/share/mutt\" -DSYSCONFDIR=\"/opt/local/etc\" -DBINDIR=\"/opt/local/bin\" -DMUTTLOCALEDIR=\"/opt/local/share/locale\" -DHAVE_CONFIG_H=1 -I. -I. -Iintl -I/opt/local/include -I./intl -I/opt/local/include -g -O2 -c addrbook.c In file included from mutt_menu.h:23,

from addrbook.c:20:

keymap.h:83: error: array type has incomplete element type make[2]: * [addrbook.o] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive-am] Error 2

comment:4 Changed 15 years ago by sharninder@…

This is because of the gcc-4.0 included with xcode 2.1. Read the discussion at:

http://gcc.gnu.org/ml/gcc/2005-02/msg00054.html

To solve the problem change the declaration at keymap.h:83 from:

extern struct mapping_t Menus[];

to

extern struct mapping_t *Menus;

You will also have to make a similar change at keymap.c:31

comment:5 Changed 15 years ago by mww@…

Summary: mutt doesn't compile with Xcode 2.1 on OS X 10.4.2BUG: mutt doesn't compile with Xcode 2.1 on OS X 10.4.2

comment:6 Changed 15 years ago by bahamat@…

After building mutt with the suggested changes to keymap.c and keymap.h mutt segfaults.

Kernel tracing shows that mutt reads the config file and then receives a SIGSEV.

comment:7 Changed 15 years ago by jay@…

Cc: jay@… added

comment:8 Changed 15 years ago by jay@…

Bug is reproducible on my machine as well. The fix suggested in comment 4 also gives me a segfault on launch.

uname -a Darwin egel.local 8.3.0 Darwin Kernel Version 8.3.0: Mon Oct 3 20:04:04 PDT 2005; root:xnu-792.6.22.obj~2/RELEASE_PPC Power Macintosh powerpc

gcc --version powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5247)

comment:9 Changed 15 years ago by brent@…

Cc: brent@… added

I get the same result as the other reporters: error message, patch attempt, seg fault. Fresh CVS checkout/install of DarwinPorts base and dports, mutt 1.4.2.1_2+imap+nntp+ssl, and:

$ uname -a Darwin gauss.local 8.3.0 Darwin Kernel Version 8.3.0: Mon Oct 3 20:04:04 PDT 2005; root:xnu-792.6.22.obj~2/RELEASE_PPC Power Macintosh powerpc $ gcc --version powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5247)

comment:10 Changed 15 years ago by yeled@…

Owner: changed from eric@… to yeled@…
Status: assignednew

comment:11 Changed 15 years ago by yeled@…

Cc: yeled@… added
Status: newassigned

a) I would recommend using mutt-devel, mutt is 2 years old. b) this should be fixable. will have alook over christmas.

comment:12 Changed 15 years ago by yeled@…

Resolution: fixed
Status: assignedclosed

I've fixed this.

Please sync and try again.

comment:13 Changed 15 years ago by satadru@…

Already using mutt-devel, thanks.

comment:14 Changed 15 years ago by brent@…

Just a note that it still fails with the "+nntp" variant. typescript attached to this bug. But I'll switch to mutt-devel; thanks.

Changed 15 years ago by brent@…

Attachment: typescript.nntp added

"port build" output

comment:15 Changed 15 years ago by yeled@…

(In reply to comment #11)

Just a note that it still fails with the "+nntp" variant. typescript

attached to

this bug. But I'll switch to mutt-devel; thanks.

I can't make this fail..

it's strange that it errors in the exact way that I just fixed?

in any case - if you'd like to open a New bug, I can look into it some more.

Note: See TracTickets for help on using tickets.