Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#43002 closed update (fixed)

cppunit: Switch to the freedesktop.org version

Reported by: nomis52@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: haspatch Cc: ryandesign (Ryan Schmidt)
Port: cppunit

Description (last modified by ryandesign (Ryan Schmidt))

The last version of the original cppunit was released in 2008 [1]. Emails to the mailing list receive no replies [2].

The freedesktop.org version [3] is maintained by Markus Mohrhard of the LibreOffice. The upcoming Debian Jessie release [4], Ubuntu 13.10 & Arch have switched to this fork.

The reason I care about this is because the current version doesn't compile cleanly with new versions of clang:

ExceptionTestCaseDecorator.h:95:55: error: unused parameter 'e' [-Werror,-Wunused-parameter]

Attachments (2)

Portfile.diff (1.3 KB) - added by nomis52@… 6 years ago.
automake.patch (395 bytes) - added by nomis52@… 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by nomis52@…

Please also delete the automake.patch file after applying the patch.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: mww@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to mww@…

comment:3 Changed 6 years ago by nomis52@…

Any updates on this? It looks like mww@ is absent.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: Switch cppunit to the use the freedesktop.org versioncppunit: Switch to the freedesktop.org version

cppunit 1.12.1 does build for me; with which version of OS X and Xcode does it not build for you?

The --mandir configure arg is no longer needed since the value it specifies is the default now. But we should add --disable-silent-rules.

You've deleted the automake patch, but I'm not sure that's best. The patch serves to replace a deprecated macro with its modern replacement. This will ensure that when a future version of autotools drops support for the deprecated macro the port doesn't then start failing to configure.

But I'm not sure if the port needs to autoreconf anymore either. That was added to fix a build failure, but I cannot reproduce that build failure, neither with 1.12.1 nor 1.13.2.

comment:5 Changed 6 years ago by nomis52@…

cppunit 1.12.1 does build for me; with which version of OS X and Xcode does it not build for you?

See https://github.com/OpenLightingProject/ola/issues/358 , in particular:

ExceptionTestCaseDecorator.h:95:55: error: unused parameter 'e' [-Werror,-Wunused-parameter]

The --mandir configure arg is no longer needed since the value it specifies is the default now. But we should add --disable-silent-rules.

Done

But I'm not sure if the port needs to autoreconf anymore either. That was added to fix a build failure, but I cannot reproduce that build failure, neither with 1.12.1 nor 1.13.2.

I can't reproduce it either, but I've left it in so I don't run the risk of breaking older versions. I've added the patchfile back as well.

Changed 6 years ago by nomis52@…

Attachment: Portfile.diff added

Changed 6 years ago by nomis52@…

Attachment: automake.patch added

comment:6 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

I've talked to Jeremy who first added the autoreconfing in r79399, and he doesn't remember the specific build failure. The configure script in cppunit 1.12.1 was made with autoconf 2.61; it's conceivable this was too old to support newer versions of OS X. The configure script in cppunit 1.13.2 was made with autoconf 2.69, which is the same version we have in MacPorts today, so I don't think autoreconfing is helping anything anymore so I'm removing it with this update.

The other reason for delay is that the library version changes with this update, so any ports linking with that library will need to be rebuilt. There are a few ports declaring library dependencies on cppunit, but it turns out most of them don't install files that link with the library; I've filed tickets for some of them to have the dependency type corrected. I haven't yet looked through all the ports that declare dependencies on cppunit but I suppose I can do that later.

Updated cppunit to 1.13.2 in r124818. I also fixed the livecheck.

comment:7 Changed 6 years ago by nomis52@…

Thanks Ryan!

Note: See TracTickets for help on using tickets.