Opened 6 years ago

Closed 6 years ago

#43110 closed defect (duplicate)

rdesktop +smartcard: Undefined symbols: "_SCARD_CTL_CODE"

Reported by: ritchymad@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cshbell@…
Port: rdesktop

Description (last modified by ryandesign (Ryan Schmidt))

The variant smartcard will not install. Please fix the scard.h and scard.c
I have already linked /opt/local/lib64 to /opt/local/lib
Last part of the log:

:notice:build --->  Building rdesktop
:debug:build Executing org.macports.build (rdesktop)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.9'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/work/rdesktop-1.7.1" && /usr/bin/make -j4 -w rdesktop'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/work/rdesktop-1.7.1" && /usr/bin/make -j4 -w rdesktop 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/work/rdesktop-1.7.1'
:info:build /usr/bin/clang -pipe -Os -arch x86_64 -Wall -I/opt/local/include -I/opt/local/include   -I/opt/local/include  -I/opt/local/include   -DPACKAGE_NAME=\"rdesktop\" -DPACKAGE_TARNAME=\"rdesktop\" -DPACKAGE_VERSION=\"1.7.1\" -DPACKAGE_STRING=\"rdesktop\ 1.7.1\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DL_ENDIAN=1 -DHAVE_SYS_SELECT_H=1 -DHAVE_SYS_FILIO_H=1 -DHAVE_LOCALE_H=1 -DHAVE_LANGINFO_H=1 -DHAVE_SYSEXITS_H=1 -Dssldir=\"/opt/local\" -DHAVE_XRANDR=1 -DWITH_SCARD=1 -DEGD_SOCKET=\"/var/run/egd-pool\" -DHAVE_LIBSAMPLERATE=1 -DWITH_RDPSND=1 -DRDPSND_LIBAO=1 -DHAVE_DIRENT_H=1 -DHAVE_DIRFD=1 -DHAVE_DECL_DIRFD=1 -DHAVE_ICONV_H=1 -DHAVE_ICONV=1 -DICONV_CONST= -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_MOUNT_H=1 -DSTAT_STATVFS=1 -DHAVE_STRUCT_STATVFS_F_NAMEMAX=1 -DKEYMAP_PATH=\"/opt/local/share/rdesktop/keymaps/\" -o rdesktop rdesktop.o xwin.o xkeymap.o ewmhints.o xclip.o cliprdr.o rdpsnd.o rdpsnd_dsp.o rdpsnd_libao.o tcp.o iso.o mcs.o secure.o licence.o rdp.o orders.o bitmap.o cache.o rdp5.o channels.o rdpdr.o serial.o printer.o disk.o parallel.o printercache.o mppc.o pstcache.o lspci.o seamless.o ssl.o scard.o -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64 -L/opt/local/lib -L/opt/local/lib -L/opt/local/lib64 -lcrypto  -L/opt/local/lib -lXrandr  -framework PCSC -L/opt/local/lib -lsamplerate  -L/opt/local/lib -lao  -liconv   -lX11
:info:build Undefined symbols for architecture x86_64:
:info:build   "_SCARD_CTL_CODE", referenced from:
:info:build       _SC_deviceControl in scard.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make: *** [rdesktop] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/work/rdesktop-1.7.1'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/work/rdesktop-1.7.1" && /usr/bin/make -j4 -w rdesktop 
:info:build Exit code: 2
:error:build org.macports.build for port rdesktop returned: command execution failed
:debug:build Error code: CHILDSTATUS 32764 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for rdesktop: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port rdesktop for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_rdesktop/rdesktop/main.log

Attachments (1)

main.log (45.3 KB) - added by ritchymad@… 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by ritchymad@…

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: cshbell@… added
Description: modified (diff)
Keywords: smartcard removed
Resolution: duplicate
Status: newclosed
Summary: sudo port install rdesktop +smartcard failed on OS X mavericks desktop version 1.7.1rdesktop +smartcard: Undefined symbols: "_SCARD_CTL_CODE"

Duplicate of #38951.

Note: See TracTickets for help on using tickets.