Opened 6 years ago

Closed 6 years ago

#43113 closed defect (duplicate)

clang-3.1 @3.1_7 fails checking out libcxx from trunk on a 10.5.8. PPC

Reported by: udbraumann Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: leopard Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: clang-3.1

Description

While trying to install clang-3.1 (to me this appears to be the last clang version capable to work for PPC) I got some trouble during the extraction phase:

:debug:extract Executing proc-post-org.macports.extract-extract-0
:info:extract sh: line 1: 61751 Bus error               svn co -r 156798 http://llvm.org/svn/llvm-project/libcxx/trunk libcxx
:info:extract Command failed: cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_llvm-3.1/clang-3.1/work/llvm-3.1.src/projects && svn co -r 156798 http://llvm.org/svn/llvm-project/libcxx/trunk libcxx
:info:extract Exit code: 138
:error:extract org.macports.extract for port clang-3.1 returned: command execution failed

Please see the main.log

Attachments (1)

main.log (39.4 KB) - added by udbraumann 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by udbraumann

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Does this always happen?

Does your svn command work otherwise, i.e. in another port, or outside of MacPorts?

Is your svn command from Mac OS X or from the MacPorts subversion port? If the former, try installing the latter.

comment:2 in reply to:  1 Changed 6 years ago by udbraumann

Replying to ryandesign@…:

Does this always happen? ...

Oh my god, yes, I suddenly notice that svn is broken, but in fact it is from the most recent Macports subversion:

$ which svn
/opt/local/bin/svn
$ svn --version
svn, version 1.8.8 (r1568071)
   compiled Feb 26 2014, 09:10:30 on powerpc-apple-darwin9.8.0

Just by renaming /opt/local/bin/svn to /opt/local/bin/svn_broken followed by hash -r the Mac OS X version (I guess) is used:

$ which svn
/usr/bin/svn
$ svn --version
svn, version 1.4.4 (r25188)
   compiled May  5 2011, 18:44:30

Fortunately this svn works, so clang-3.1 now is building.

One should inform the subversion maintainer ...


Edit: I have opened a ticket describing that svn from Macports issues a "Bus error" at checkout, at least on my 10.5.8. PPC: https://trac.macports.org/ticket/43116

Last edited 6 years ago by udbraumann (previous) (diff)

comment:3 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: duplicate
Status: newclosed

FWIW, I would definitely not recommend using llvm-3.1 for darwin/ppc. I don't think darwin/ppc was ever finished, but I think there was more work that went into 3.3 that might make it somewhat usable.

A separate ticket wasn't really needed. We'll close this as a dupe of #43116 then.

Note: See TracTickets for help on using tickets.