Opened 7 years ago

Closed 5 years ago

#43500 closed defect (duplicate)

xorg-server @1.14.5.901 (x11, devel) Configure error - build failure

Reported by: iology (J.W) Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: base Version: 2.2.1
Keywords: Cc:
Port:

Description

OS: OS X 10.9.2

I have already installed xorg-server@1.14.4_0 before sudo port upgrade outdated

The main information I saw in the log file:

:info:configure configure.ac:36: error: must install xorg-macros 1.14 or later before running autoconf/autogen

But I saw that xorg-util-macros is in the dependency list, no xorg-macros:

~  port echo depof:xorg-server
autoconf                        
automake                        
libpixman                       
libtool                         
mesa                            
pkgconfig                       
quartz-wm                       
xinit                           
xkeyboard-config                
xorg-applewmproto               
xorg-bigreqsproto               
xorg-damageproto                
xorg-fixesproto                 
xorg-font-util                  
xorg-fonts                      
xorg-fontsproto                 
xorg-glproto                    
xorg-inputproto                 
xorg-libAppleWM                 
xorg-libXfixes                  
xorg-libXfont                   
xorg-libxkbfile                 
xorg-libXt                      
xorg-randrproto                 
xorg-recordproto                
xorg-renderproto                
xorg-resourceproto              
xorg-scrnsaverproto             
xorg-util-macros                
xorg-videoproto                 
xorg-xcmiscproto                
xorg-xextproto                  
xorg-xineramaproto              
xorg-xproto                     
xorg-xtrans

For the full error log, please see the attachment.

Attachments (3)

main.log (4.7 KB) - added by iology (J.W) 7 years ago.
main.2.log (142.2 KB) - added by cooljeanius (Eric Gallager) 7 years ago.
a successful configure of xorg-server
main.3.log (5.4 KB) - added by iology (J.W) 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by iology (J.W)

Attachment: main.log added

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jeremyhu@…

In the future, please Cc the port maintainers (port info --maintainers xorg-server).

comment:2 in reply to:  1 Changed 7 years ago by iology (J.W)

Replying to mf2k@…:

In the future, please Cc the port maintainers (port info --maintainers xorg-server).

Thanks.

And, for the maintainers: I have to manually install autoconf for autoreconf not found error before this issue. Maybe the dependency checking was unstable, I guess?

comment:3 Changed 7 years ago by cooljeanius (Eric Gallager)

But I saw that xorg-util-macros is in the dependency list, no xorg-macros

That is just a different name for the same package. What version of xorg-util-macros do you have installed? Mine is:

$ port installed xorg-util-macros
The following ports are currently installed:
  xorg-util-macros @1.17.1_0
  xorg-util-macros @1.19.0_0 (active)

btw xorg-server configured successfully for me; I will attach my own log for comparison...

Changed 7 years ago by cooljeanius (Eric Gallager)

Attachment: main.2.log added

a successful configure of xorg-server

comment:4 in reply to:  3 Changed 7 years ago by iology (J.W)

Replying to egall@…:

But I saw that xorg-util-macros is in the dependency list, no xorg-macros

That is just a different name for the same package. What version of xorg-util-macros do you have installed? Mine is:

$ port installed xorg-util-macros
The following ports are currently installed:
  xorg-util-macros @1.17.1_0
  xorg-util-macros @1.19.0_0 (active)

btw xorg-server configured successfully for me; I will attach my own log for comparison...

Thanks. But I think the successful log is not useful for me. The real problem maybe was revealed by comment:2. Macports didn't install the dependencies for xorg-server, that's so weird.

And now I have tried to manually install xorg-util-macros, and manually install xorg-font-util, finally I met another failure:

63 :info:configure configure.ac:678: error: possibly undefined macro: XTRANS_CONNECTION_FLAGS
64 :info:configure       If this token and others are legitimate, please use m4_pattern_allow.
65 :info:configure       See the Autoconf documentation.

log file will be attached soon. (Well, maybe I need to manually install all dependencies...)

Last edited 7 years ago by iology (J.W) (previous) (diff)

Changed 7 years ago by iology (J.W)

Attachment: main.3.log added

comment:5 in reply to:  description Changed 7 years ago by iology (J.W)

Well, I have tried to manually install all missing dependencies of xorg-server,

~ sudo port upgrade $(port echo depof:xorg-server)
Error: xorg-bigreqsproto is not installed
Error: xorg-resourceproto is not installed
Error: xorg-scrnsaverproto is not installed
Error: xorg-xcmiscproto is not installed
Error: xorg-xtrans is not installed
~ sudo port install xorg-util-macros xorg-font-util xorg-bigreqsproto xorg-resourceproto xorg-scrnsaverproto xorg-xcmisproto xorg-xtrans
~ sudo port upgrade outdated

and it was so successful when upgrading xorg-server. :-)

Then I uninstalled the new one and dependencies I manually installed, and re-upgrade the old one. Although it was successful again, but I found that some dependencies were not installed at all! Maybe MacPorts has gone mad on my computer? I don't want to reinstall MacPorts. That's painful. I hope this is just a problem related to xorg-server port.

Last edited 7 years ago by iology (J.W) (previous) (diff)

comment:6 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Component: portsbase
Owner: changed from jeremyhu@… to jmr@…
Port: xorg-server removed

What do you mean you "manually installed, and re-upgrade the old one"

As this has nothing to do with xorg-server but rather missing dependencies, I'm moving to base.

comment:7 in reply to:  6 ; Changed 7 years ago by iology (J.W)

Replying to jeremyhu@…:

What do you mean you "manually installed, and re-upgrade the old one"

As this has nothing to do with xorg-server but rather missing dependencies, I'm moving to base.

Let me describe the whole process from the start.

  1. I had already installed xorg-server@1.14.4_0 which has been upgraded successfully several times.
  2. After port selfupdate, I ran port upgrade outdated as normal.
  3. Configure error about autoreconf occurred, I manually installed automake, autoconf, libtool by port install automake autoconf libtool to solve the problem.
  4. Then configure errors about all other missing dependencies xorg-util-macros, xorg-font-util, xorg-bigreqsproto, xorg-resourceproto, xorg-scrnsaverproto, xorg-xcmisproto, xorg-xtrans occurred. I solved it with the same method stated before.
  5. Finally, xorg-server was successfully installed.

After that, I uninstalled xorg-server and all the dependencies except libtool, and tryied to reinstall again. This time, both port upgrade outdated and port install xorg-server did calculate the dependency information, but did not install all the missing dependencies for xorg-server as port echo depof:xorg-server showed.

The installation:

~ sudo port install xorg-server
--->  Computing dependencies for xorg-server
--->  Dependencies to be installed: quartz-wm xinit xkeyboard-config xorg-fonts xorg-libXfont
--->  Fetching archive for quartz-wm
--->  Attempting to fetch quartz-wm-1.3.1_1.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/quartz-wm
--->  Attempting to fetch quartz-wm-1.3.1_1.darwin_13.x86_64.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/quartz-wm
--->  Installing quartz-wm @1.3.1_1
--->  Activating quartz-wm @1.3.1_1
--->  Cleaning quartz-wm
--->  Fetching archive for xinit
--->  Attempting to fetch xinit-1.3.3_1.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/xinit
--->  Attempting to fetch xinit-1.3.3_1.darwin_13.x86_64.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xinit
--->  Installing xinit @1.3.3_1
--->  Activating xinit @1.3.3_1
###############################################################################
# To choose MacPorts' X11 as the default server, you must install xorg-server,
# logout, and log back in.
###############################################################################
--->  Cleaning xinit
--->  Fetching archive for xkeyboard-config
--->  Attempting to fetch xkeyboard-config-2.5.1_0.darwin_13.noarch.tbz2 from http://jog.id.packages.macports.org/macports/packages/xkeyboard-config
--->  Attempting to fetch xkeyboard-config-2.5.1_0.darwin_13.noarch.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xkeyboard-config
--->  Installing xkeyboard-config @2.5.1_0
--->  Activating xkeyboard-config @2.5.1_0
--->  Cleaning xkeyboard-config
--->  Fetching archive for xorg-fonts
--->  Attempting to fetch xorg-fonts-20090102_1.darwin_13.noarch.tbz2 from http://jog.id.packages.macports.org/macports/packages/xorg-fonts
--->  Attempting to fetch xorg-fonts-20090102_1.darwin_13.noarch.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xorg-fonts
--->  Installing xorg-fonts @20090102_1
--->  Activating xorg-fonts @20090102_1
--->  Cleaning xorg-fonts
--->  Fetching archive for xorg-libXfont
--->  Attempting to fetch xorg-libXfont-1.4.7_0.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/xorg-libXfont
--->  Attempting to fetch xorg-libXfont-1.4.7_0.darwin_13.x86_64.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xorg-libXfont
--->  Installing xorg-libXfont @1.4.7_0
--->  Activating xorg-libXfont @1.4.7_0
--->  Cleaning xorg-libXfont
--->  Fetching archive for xorg-server
--->  Attempting to fetch xorg-server-1.14.5.901_0.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/xorg-server
--->  Attempting to fetch xorg-server-1.14.5.901_0.darwin_13.x86_64.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xorg-server
--->  Installing xorg-server @1.14.5.901_0
--->  Activating xorg-server @1.14.5.901_0
--->  Cleaning xorg-server
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

Check dependencies computing:

~ sudo port -y install $(port echo depof:xorg-server)
--->  Computing dependencies for autoconf
For autoconf: skipping org.macports.main (dry run)
--->  Computing dependencies for automake
For automake: skipping org.macports.main (dry run)
For libpixman: skipping org.macports.main (dry run)
For libtool: skipping org.macports.main (dry run)
--->  Computing dependencies for mesa
For mesa: skipping org.macports.main (dry run)
`--->  Computing dependencies for pkgconfig
For pkgconfig: skipping org.macports.main (dry run)
--->  Computing dependencies for quartz-wm
For quartz-wm: skipping org.macports.main (dry run)
--->  Computing dependencies for xinit
For xinit: skipping org.macports.main (dry run)
--->  Computing dependencies for xkeyboard-config
For xkeyboard-config: skipping org.macports.main (dry run)
For xorg-applewmproto: skipping org.macports.main (dry run)
For xorg-bigreqsproto: skipping org.macports.main (dry run)
For xorg-damageproto: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-fixesproto
For xorg-fixesproto: skipping org.macports.main (dry run)
For xorg-font-util: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-fonts
For xorg-fonts: skipping org.macports.main (dry run)
For xorg-fontsproto: skipping org.macports.main (dry run)
For xorg-glproto: skipping org.macports.main (dry run)
For xorg-inputproto: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-libAppleWM
For xorg-libAppleWM: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-libXfixes
For xorg-libXfixes: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-libXfont
For xorg-libXfont: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-libxkbfile
For xorg-libxkbfile: skipping org.macports.main (dry run)
--->  Computing dependencies for xorg-libXt
For xorg-libXt: skipping org.macports.main (dry run)
For xorg-randrproto: skipping org.macports.main (dry run)
For xorg-recordproto: skipping org.macports.main (dry run)
For xorg-renderproto: skipping org.macports.main (dry run)
For xorg-resourceproto: skipping org.macports.main (dry run)
For xorg-scrnsaverproto: skipping org.macports.main (dry run)
For xorg-util-macros: skipping org.macports.main (dry run)
For xorg-videoproto: skipping org.macports.main (dry run)
For xorg-xcmiscproto: skipping org.macports.main (dry run)
For xorg-xextproto: skipping org.macports.main (dry run)
For xorg-xineramaproto: skipping org.macports.main (dry run)
For xorg-xproto: skipping org.macports.main (dry run)
For xorg-xtrans: skipping org.macports.main (dry run)

Check upgrade dependencies:

~ sudo port -y upgrade $(port echo depof:xorg-server)           
Error: autoconf is not installed
Error: automake is not installed
Error: pkgconfig is not installed
Error: xorg-bigreqsproto is not installed
Error: xorg-font-util is not installed
Error: xorg-resourceproto is not installed
Error: xorg-scrnsaverproto is not installed
Error: xorg-util-macros is not installed
Error: xorg-xcmiscproto is not installed
Error: xorg-xtrans is not installed

comment:8 in reply to:  7 ; Changed 7 years ago by jmroot (Joshua Root)

Replying to jakwings@…:

The installation:

~ sudo port install xorg-server
--->  Computing dependencies for xorg-server
--->  Dependencies to be installed: quartz-wm xinit xkeyboard-config xorg-fonts xorg-libXfont

--->  Fetching archive for xorg-server
--->  Attempting to fetch xorg-server-1.14.5.901_0.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/xorg-server
--->  Attempting to fetch xorg-server-1.14.5.901_0.darwin_13.x86_64.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xorg-server
--->  Installing xorg-server @1.14.5.901_0
--->  Activating xorg-server @1.14.5.901_0

Here you installed from an archive, so the build-time dependencies were not needed.

comment:9 in reply to:  8 Changed 7 years ago by iology (J.W)

Replying to jmr@…:

Replying to jakwings@…:

The installation:

~ sudo port install xorg-server
--->  Computing dependencies for xorg-server
--->  Dependencies to be installed: quartz-wm xinit xkeyboard-config xorg-fonts xorg-libXfont

--->  Fetching archive for xorg-server
--->  Attempting to fetch xorg-server-1.14.5.901_0.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/xorg-server
--->  Attempting to fetch xorg-server-1.14.5.901_0.darwin_13.x86_64.tbz2.rmd160 from http://jog.id.packages.macports.org/macports/packages/xorg-server
--->  Installing xorg-server @1.14.5.901_0
--->  Activating xorg-server @1.14.5.901_0

Here you installed from an archive, so the build-time dependencies were not needed.

Even when upgrading? How can I solve the old problem related to my manually installation for dependencies?

comment:10 Changed 7 years ago by jmroot (Joshua Root)

Yes, even when upgrading. I don’t know how you got into a state where it thought an archive was not available, which made it build from source, but still didn’t install the build deps. But it looks like probably cleaning was all it took to get out of that state (wiki:FAQ#buildfails).

comment:11 Changed 5 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Most likely a dupe of #34547.

Note: See TracTickets for help on using tickets.