Opened 4 years ago

Last modified 5 months ago

#43622 assigned defect

freehdl @0.0.7: error: unknown template name 'hash'

Reported by: bengt.nilsson@… Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: jeisch@…, maehne (Torsten Maehne), dimkab, global667
Port: freehdl

Description (last modified by ryandesign (Ryan Schmidt))

Tried to install qucs, dependent of freehdl, which build failed.

--->  Computing dependencies for freehdl
--->  Building freehdl
Error: for port freehdl returned: command execution failed
Please see the log file for port freehdl for details:

MacPorts base version 2.2.1 installed

Systemversion:	OS X 10.9.2 (13C1021)
 Kärnversion:	Darwin 13.1.0
Modellnamn:	Mac Pro
  Modellidentifierare:	MacPro5,1
  Processornamn:	Quad-Core Intel Xeon
  Processorhastighet:	2.8 GHz
  Antal processorer:	1
  Totalt antal kärnor:	4
  L2-cache (per kärna):	256 K
  L3-cache:	8 MB
  Minne:	32 GB

Attachments (1)

main.log (18.9 KB) - added by bengt.nilsson@… 4 years ago.
Build log for freehdl

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by bengt.nilsson@…

Build log for freehdl

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)
  • Owner changed from macports-tickets@… to rowue@…
  • Summary changed from port freehdl @0.0.7 build error to freehdl @0.0.7: error: unknown template name 'hash'

comment:2 Changed 4 years ago by guitorri@…

I am not using MacPorts, but the hash issue might be solved along the lines of:

It compiles, however it requires the libstc++:

CXX=clang++ CXXFLAGS=-stdlib=libstdc++ ./configure

Using libc++ it will choke as below... Perhaps you guys know how to fix this. error: calling a private constructor of class 'std::__1::__wrap_iter<std::__1::vector<std::__1::pair<IIR_Type *, IIR_Type *>,
      std::__1::allocator<std::__1::pair<IIR_Type *, IIR_Type *> > > *>'
          association_type_map [key] = (vector<vector<pair<pIIR_Type, pIIR_Type > > >::iterator) &association_type_vectors [i];
/Applications/ note: declared private here
    _LIBCPP_INLINE_VISIBILITY __wrap_iter(iterator_type __x) _NOEXCEPT : __i(__x) {}

My compiler:

~/build/freehdl-0.0.8 $ clang++ --version
Apple LLVM version 5.1 (clang-503.0.38) (based on LLVM 3.4svn)
Target: x86_64-apple-darwin13.2.0
Thread model: posix 

comment:3 Changed 4 years ago by gnvien@…

I have the same problem when trying to install Qucs on Mavericks : "Error: Failed to install freehdl"

Any patches for freehdl ?

Many thanks

comment:4 Changed 3 years ago by jeisch@…

  • Cc jeisch@… added

Cc Me!

comment:5 Changed 3 years ago by maehne (Torsten Maehne)

  • Cc Torsten.Maehne@… added

Cc Me!

comment:6 Changed 3 years ago by dimkab

  • Cc dima.batenkov@… added

Cc Me!

comment:7 Changed 17 months ago by ryandesign (Ryan Schmidt)

  • Cc global667 added

Has duplicate #52807.

comment:8 Changed 6 months ago by kurthindenburg (Kurt Hindenburg)

  • Owner rowue@… deleted
  • Status changed from new to assigned

comment:9 Changed 5 months ago by rshuston

Using the suggestion from guitorri @, I was able to get it to build by adding

configure.cmd CXX=clang++ CXXFLAGS=-stdlib=libstdc++ ./configure

to the end of:


Last edited 5 months ago by rshuston (previous) (diff)
Note: See TracTickets for help on using tickets.