Opened 5 years ago

Closed 5 years ago

#43846 closed defect (fixed)

frei0r-plugins @1.4: Checksum mismatch; The non-matching file appears to be HTML

Reported by: ksee.zelgadis@… Owned by: ddennedy (Dan Dennedy)
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: haspatch Cc: ryandesign (Ryan Schmidt)
Port: frei0r-plugins

Description

Hello! I've got an error when attempting to install frei0r-plugins package:

--->  Computing dependencies for fontconfig
--->  Cleaning fontconfig
--->  Computing dependencies for freetype
--->  Cleaning freetype
--->  Computing dependencies for gettext
--->  Cleaning gettext
--->  Computing dependencies for ImageMagick
--->  Cleaning ImageMagick
--->  Computing dependencies for libmng
--->  Cleaning libmng
--->  Computing dependencies for libpng
--->  Cleaning libpng
--->  Cleaning libsigcxx2
--->  Cleaning libtool
--->  Computing dependencies for libxmlxx2
--->  Cleaning libxmlxx2
--->  Computing dependencies for mlt
--->  Dependencies to be installed: frei0r-plugins git-core p5.16-error p5.16-net-smtp-ssl p5.16-io-socket-ssl p5.16-net-libidn p5.16-net-ssleay p5.16-term-readkey rsync libdv libsamplerate libsndfile flac qt4-mac sox libid3tag libmad libmagic opencore-amr twolame wavpack
--->  Fetching distfiles for frei0r-plugins
--->  Attempting to fetch frei0r-plugins-1.4.tar.gz from http://ftp.dyne.org/frei0r/releases/
--->  Verifying checksums for frei0r-plugins                                         
Error: Checksum (sha1) mismatch for frei0r-plugins-1.4.tar.gz
Error: Checksum (rmd160) mismatch for frei0r-plugins-1.4.tar.gz
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
The file has been moved to: /Users/Admin/src/macports/SynfigStudio-app/Contents/Resources/var/macports/distfiles/frei0r-plugins/frei0r-plugins-1.4.tar.gz.html
Error: org.macports.checksum for port frei0r-plugins returned: Unable to verify file checksums
Error: Failed to install frei0r-plugins
Please see the log file for port frei0r-plugins for details:
    /tmp/skl/SynfigStudio/Contents/Resources/var/macports/logs/_Users_Admin_src_macports_SynfigStudio-app_Contents_Resources_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_frei0r-plugins/frei0r-plugins/main.log
Error: The following dependencies were not installed: frei0r-plugins git-core p5.16-error p5.16-net-smtp-ssl p5.16-io-socket-ssl p5.16-net-libidn p5.16-net-ssleay p5.16-term-readkey rsync libdv libsamplerate libsndfile flac qt4-mac sox libid3tag libmad libmagic opencore-amr twolame wavpack
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port mlt failed

I guess something wrong with download URL.

(Probably it is required to execute "port clean --dist frei0r-plugins" before you can reproduce the problem).

Attachments (1)

frei0r-plugins.diff (627 bytes) - added by ryandesign (Ryan Schmidt) 5 years ago.
proposed patch

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; dan@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to dan@…
Port: frei0r-plugins added
Summary: frei0r-plugins - Unable to fetch sourcefrei0r-plugins @1.4: Checksum mismatch; The non-matching file appears to be HTML

Yes, their web server now serves an interstitial page asking for donations before redirecting to the actual file. The attached patch fixes this (and also removes the unnecessary worksrcdir line). Dan, if you have no objections, I'm happy to commit it for you.

Changed 5 years ago by ryandesign (Ryan Schmidt)

Attachment: frei0r-plugins.diff added

proposed patch

comment:2 Changed 5 years ago by ddennedy (Dan Dennedy)

Hi Ryan, A better URL to use is https://releases.dyne.org/frei0r/releases/ I was trying to test my own patch, but I was struggling to figure out how to bypass distfiles.macports.org! Please tell. Otherwise, I am fine for you to use either URL and commit this.

comment:3 Changed 5 years ago by ksee.zelgadis@…

Hello! Should I test the patch myself or wait for the fix committed? I'm not sure how to apply the patch.

comment:4 Changed 5 years ago by ksee.zelgadis@…

Hello! frei0r-plugins installation worked fine for me today. Although, looks like a different mirror was used. Thank you!

...
--->  Computing dependencies for mlt
--->  Dependencies to be installed: frei0r-plugins git-core p5.16-error p5.16-net-smtp-ssl p5.16-io-socket-ssl p5.16-net-libidn p5.16-net-ssleay p5.16-term-readkey rsync libdv libsamplerate libsndfile flac qt4-mac sox libid3tag libmad libmagic opencore-amr twolame wavpack
--->  Fetching distfiles for frei0r-plugins
--->  Attempting to fetch frei0r-plugins-1.4.tar.gz from http://nue.de.distfiles.macports.org/macports/distfiles/frei0r-plugins
--->  Verifying checksums for frei0r-plugins                                         
--->  Extracting frei0r-plugins
--->  Applying patches to frei0r-plugins
--->  Configuring frei0r-plugins
--->  Building frei0r-plugins
--->  Staging frei0r-plugins into destroot
--->  Installing frei0r-plugins @1.4_1
--->  Activating frei0r-plugins @1.4_1
--->  Cleaning frei0r-plugins
...

comment:5 in reply to:  2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to dan@…:

Hi Ryan, A better URL to use is https://releases.dyne.org/frei0r/releases/

Agreed, that's even better. Fixed in r120567.

I was trying to test my own patch, but I was struggling to figure out how to bypass distfiles.macports.org! Please tell. Otherwise, I am fine for you to use either URL and commit this.

MacPorts picks a server to use based on which one has the lowest ping time. I'm not sure how to bypass that choice. I thought there was a setting one could use to in effect blacklist certain servers, but I could not find mention of it in macports.conf.

Note: See TracTickets for help on using tickets.