Opened 6 years ago

Closed 6 years ago

#43994 closed defect (duplicate)

php54-intl @5.4.29 and php55-intl @5.5.13 cannot load icu dylib

Reported by: jonasjonas (Frank Hellenkamp) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: Cc:
Port: php54-intl

Description

After the last update of icu php cannot load the intl.so because it cannot find the corresponding libicui18n:

PHP Warning: PHP Startup: Unable to load dynamic library '/opt/local/lib/php54/extensions/no-debug-non-zts-20100525/intl.so' - dlopen(/opt/local/lib/php54/extensions/no-debug-non-zts-20100525/intl.so, 9): Library not loaded: /opt/local/lib/libicui18n.51.dylib

Referenced from: /opt/local/lib/php54/extensions/no-debug-non-zts-20100525/intl.so Reason: image not found in Unknown on line 0

I reinstalled the ice, php54 and php54-intl extensions but to no avail.

I also tried to force upgrade all ports dependent on ice: port -nR upgrade --force icu

They same problems appears to happen with php55 and php55-intl

Change History (2)

comment:1 Changed 6 years ago by pixilla (Bradley Giesbrecht)

Duplicate of #43983

comment 2 of #43983 should work as a temporary fix until phpxx-intl is rev bumped.

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Keywords: php icu removed
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.