Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#44199 closed defect (fixed)

gnutls 3.3.5 org.macports.fetch for port gnutls returned: fetch failed

Reported by: phoglund@… Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: haspatch Cc: denpashogai@…, paul.vernaza@…, ryandesign (Ryan Schmidt)
Port: gnutls

Description (last modified by mf2k (Frank Schima))

I'm trying to run

sudo port install gnutls

And I get

--->  Fetching archive for gnutls
--->  Attempting to fetch gnutls-3.3.5_0.darwin_13.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/gnutls
--->  Attempting to fetch gnutls-3.3.5_0.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/gnutls
--->  Attempting to fetch gnutls-3.3.5_0.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/gnutls
--->  Fetching distfiles for gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://nue.de.distfiles.macports.org/macports/distfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://lil.fr.distfiles.macports.org/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://her.gr.distfiles.macports.org/mirrors/macports/mpdistfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://distfiles.macports.org/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://sea.us.distfiles.macports.org/macports/distfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://cjj.kr.distfiles.macports.org/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://jog.id.distfiles.macports.org/macports/mpdistfiles/gnutls
--->  Attempting to fetch gnutls-3.3.5.tar.xz from http://svn.macports.org/repository/macports/distfiles/gnutls
Error: org.macports.fetch for port gnutls returned: fetch failed
Error: Failed to install gnutls

Attaching the resulting log file, where all servers seem to report this or similar:

notice:fetch --->  Attempting to fetch gnutls-3.3.5.tar.xz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/gnutls
:debug:fetch Fetching distfile failed: The requested URL returned error: 404 Not Found

Attachments (2)

main.log (5.7 KB) - added by phoglund@… 5 years ago.
Portfile-gnutls.diff (797 bytes) - added by Schamschula (Marius Schamschula) 5 years ago.

Download all attachments as: .zip

Change History (19)

Changed 5 years ago by phoglund@…

Attachment: main.log added

comment:1 Changed 5 years ago by phoglund@…

Note: I did manage to install another package (in this case the 'lame' package), and it worked just fine.

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to mschamschula@…

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers gnutls).

comment:4 Changed 5 years ago by Schamschula (Marius Schamschula)

I'm not sure what is going on here. The binary files may not have been built by the MacPorts buildbot, but your system should download the source files and build it locally.

This too seems to have failed.

I just double checked the GNU master site:

ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/

and found the archive to be present. I just had four iMacs in my department's computer lab fetch these tar balls and build gnutls 3.3.5, w/o any problems.

Do you have a DNS issue?

comment:5 in reply to:  4 ; Changed 5 years ago by phoglund@…

Replying to mschamschula@…:

I'm not sure what is going on here. The binary files may not have been built by the MacPorts buildbot, but your system should download the source files and build it locally.

This too seems to have failed.

I just double checked the GNU master site:

ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/

and found the archive to be present. I just had four iMacs in my department's computer lab fetch these tar balls and build gnutls 3.3.5, w/o any problems.

Do you have a DNS issue?

Uh, alright. Do you mean you manually fetched the tarballs from gnutls.org and built manually?

As far I can see the 404's from the mirrors are correct; for instance, looking at

http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/gnutls/

reveals there is no file for 3.3.5. Is it supposed to build locally from source when none of the mirrors yields a hit? Looks in the log like it gives up after all the mirrors give 404's.

comment:6 in reply to:  5 Changed 5 years ago by Schamschula (Marius Schamschula)

Replying to phoglund@…:

Replying to mschamschula@…:

I'm not sure what is going on here. The binary files may not have been built by the MacPorts buildbot, but your system should download the source files and build it locally.

This too seems to have failed.

I just double checked the GNU master site:

ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/

and found the archive to be present. I just had four iMacs in my department's computer lab fetch these tar balls and build gnutls 3.3.5, w/o any problems.

Do you have a DNS issue?

Uh, alright. Do you mean you manually fetched the tarballs from gnutls.org and built manually?

As far I can see the 404's from the mirrors are correct; for instance, looking at

http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/gnutls/

reveals there is no file for 3.3.5. Is it supposed to build locally from source when none of the mirrors yields a hit? Looks in the log like it gives up after all the mirrors give 404's.

Nope. Nothing manual about my builds this morning, matter of fact they were part of a

sudo port upgrade outdated

run.

404s are not uncommon, thats why MacPorts checks multiple sites.

However, in this case there is something wrong with the MacPorts infrastructure, as the mirrors have not fetched any of the gnutls 3.3.x tar balls.

Yet the above mentioned ftp site should not have failed.

comment:7 Changed 5 years ago by Schamschula (Marius Schamschula)

Apparently the issue is that your ftp connection times out. Has ftp been blocked by a firewall or router?

comment:8 Changed 5 years ago by phoglund@…

That's possible. I tried doing a manual ftp ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/gnutls-3.3.0.tar.xz , and the ftp client dies with Abort: trap 6.

Is there any way to download the archive manually through other means and put it in the right place? Also, any luck fixing the infrastructure problems so the prebuilt binaries get distributed to the mirrors?

comment:9 Changed 5 years ago by phoglund@…

Ping.

Or can I tell macports to install an older, mirrored version of gnutls to work around the problem (providing that the packages I need are still compatible).

comment:10 Changed 5 years ago by denpashogai@…

Hi, I'm experiencing this problem as well. "port upgrade outdated" will not complete because it fails at this point.

$ cat /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gnutls/gnutls/main.log
...
:notice:fetch --->  Attempting to fetch gnutls-3.3.5.tar.xz from ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/
:debug:fetch Fetching distfile failed: Operation too slow. Less than 1024 bytes/sec transferred the last 60 seconds
...
:error:fetch org.macports.fetch for port gnutls returned: fetch failed

What's bizarre is that I can download the archive using wget with no problems:

$ wget ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/gnutls-3.3.5.tar.xz
...
==> PASV ... done.    ==> RETR gnutls-3.3.5.tar.xz ... done.
...
2014-07-04 15:51:58 (6.08 MB/s) - ‘gnutls-3.3.5.tar.xz’ saved [6007316]
$ file gnutls-3.3.5.tar.xz
gnutls-3.3.5.tar.xz: xz compressed data
Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:11 Changed 5 years ago by denpashogai@…

Cc: denpashogai@… added

Cc Me!

comment:12 Changed 5 years ago by Schamschula (Marius Schamschula)

It occurred to me that I already have been mirroring gnutls on the hmug.org server, via http. So I added this to the master_sites list.

Changed 5 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile-gnutls.diff added

comment:13 Changed 5 years ago by paul.vernaza@…

Cc: paul.vernaza@… added

Cc Me!

comment:14 Changed 5 years ago by hietler@…

I just went to the official gnutls site and downloaded gnutls-3.3.5.tar.xz to .../var/macports/distfiles/gnutls/

this worked fine as a workaround.

Last edited 5 years ago by hietler@… (previous) (diff)

comment:15 Changed 5 years ago by phoglund@…

Yeah, a

sudo mv ~/Downloads/gnutls-3.3.5.tar.xz /opt/local/var/macports/distfiles/gnutls/

works around the problem. I think this ticket should stay open until it's fixed though. Thanks hietler!

comment:16 Changed 5 years ago by neverpanic (Clemens Lang)

Isn't GnuTLS available from all GNU mirrors (browser:trunk/dports/_resources/port1.0/fetch/mirror_sites.tcl#L219)? If so, shouldn't we just set master_sites gnu:${name} or something?

Also, the list of GNU mirrors in mirror_sites.tcl seems to be pretty out of date, we should probably update it.

Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:17 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: haspatch added
Resolution: fixed
Status: newclosed

Everyone: please use WikiFormatting and TracLinks when writing in Trac so that your posts are legible and so that we don't have to edit your formatting later.

mschamschula: there is no reason to increase the port's revision when just changing the list of master sites. And remember to add the "haspatch" keyword when you attach a patch.

phoglund: yes, you can fetch distfiles manually and place them where MacPorts expects them. The process is documented in ProblemHotlist#fetch-failures. Yes, you can install an older version of a port, documented in wiki:howto/InstallingOlderPort. You shouldn't do this, however, because other ports have already been built against the new version of gnutls; you might get library version mismatches if you get some of those dependencies via a binary package from our server. Binaries of the current version are not available—not because of an infrastructure problem, but because of a license conflict:

"gnutls" is not distributable because its license "gpl" conflicts with license "OpenSSL" of dependency "openssl"

cal: old versions of gnutls are on the gnu mirrors, but current versions are only hosted at the gnutls ftp server.

MacPorts' distfiles mirror servers should mirror files, but sometimes this fails. In particular, Apple's network (which is where Mac OS Forge lives and where MacPorts' servers are hosted) has restrictions on accessing FTP servers over their normal ports. To circumvent this, the MacPorts servers are configured to use a proxy server run by another MacPorts committer on a different network, but during Mac OS Forge's recent network reconfiguration this connection was interrupted for a time. Separately, shortly after that, the proxy server was down for awhile. Probably gnutls was updated to 3.3.5 during one of these outages so the file did not get mirrored.

I've committed mschamschula's patch (minus the revision increase) in r122069. This does not appear to have caused the servers to re-attempt mirroring, perhaps because the port had already been successfully built. However this might let you fetch it now, and hopefully the files will get mirrored eventually, the next time the gnutls port has its revision or version increased; I may have a change I need to commit to it shortly which would cause this.

Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)
Note: See TracTickets for help on using tickets.