Opened 7 years ago

Closed 4 years ago

#44206 closed defect (fixed)

py-readline broken for Python 3.4, upgrade to new gnureadline 6.3.3

Reported by: ned-deily (Ned Deily) Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc: larryv (Lawrence Velázquez), petrrr, ryandesign (Ryan Schmidt)
Port: py-readline

Description

The current py-readline port is broken for Python 3.4. It's fixed upstream but the upstream project has been renamed to gnureadline and moved:

https://pypi.python.org/pypi/gnureadline

https://github.com/ludwigschwardt/python-gnureadline

Attachments (1)

Portfile (1.6 KB) - added by petrrr 7 years ago.
py-gnureadline/Portfile

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:2 Changed 7 years ago by petrrr

Owner: changed from macports-tickets@… to petr@…
Status: newassigned

comment:3 Changed 7 years ago by petrrr

Cc: petr@… removed

Cc Me!

comment:4 Changed 7 years ago by petrrr

I would propose that we rename the port as well, to avoid any confusion in future.

Changed 7 years ago by petrrr

Attachment: Portfile added

py-gnureadline/Portfile

comment:5 Changed 7 years ago by larryv (Lawrence Velázquez)

I presume that the py-gnureadline Portfile is not very different from the py-readline one. If you do this, please use svn copy to create the py-gnureadline directory and maintain history.

comment:6 Changed 7 years ago by petrrr

Jop, already done. The copy I attached builds correctly, but I'd like to look at the purpose of the old patches. Unfortunately, I am not a user of this port, so I am not sure how to test.

comment:7 Changed 7 years ago by ned-deily (Ned Deily)

This is actually rather more serious than I originally thought. The problem is that the upstream ports bundle into them a source file from the Python source distribution and the original, un-updated upstream version is now way out of date for all Python versions. Taking a quick look at the existing MacPorts patches, the universal build stuff has changed a bit in the new version and I think it can still be safely removed; likewise for the 10.9.5 / Xcode 5 workaround which only applies to the Apple-supplied Pythons. The patches for readline_path.py and readline.pth and the extra_path patch to setup.py are still needed, I think: they simulate what a setuptools install would do to alter sys.path. ticket:45301#comment:9 has some details on what you should expect to see if pyxx-readline is properly installed. If you like, I would be willing to smoke test the port if you can make the updates available.

comment:8 Changed 6 years ago by ned-deily (Ned Deily)

Ping?

comment:9 Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:10 Changed 6 years ago by petrrr

Yes, this is still pending. I try to have a look at this again. If you have appropriate patches, just attach them here.

comment:11 Changed 6 years ago by petrrr

Owner: changed from petr@… to stromnov@…
Status: assignednew

A py-gnureadline port seems to have been committed in r139351. Therefore I reassign to the maintainer of the new port.

This seems to have happened independently of this ticket and does not derive from py-readline and does not replace it.

So the doubt is:

  • can py-readline be replaced_by py-gnureadline now?
  • is the patching seen in the older py-readline port still relevant?

I have found only one dependency on the older port: scapy.

comment:12 Changed 6 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:13 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

Andrew, is there any reason why we cannot replace py-readline and its subports with py-gnureadline and its subports?

What is the situation with the patchfiles in py-readline—should they be incorporated into py-gnureadline or are they no longer relevant?

comment:14 Changed 4 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

In 9beeded98a3eba28030e4993153a037366f5bda5/macports-ports:

py-readline: replaced_by py-gnureadline

Fixes: #44206

Note: See TracTickets for help on using tickets.