Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#44252 closed defect (fixed)

Attempting to install Qtiplot causes check-sum mismatch

Reported by: other@… Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc:
Port: qtiplot

Description (last modified by neverpanic (Clemens Lang))

Attempting to install qtiplot like this:

sudo port install qtiplot +qtexengine +python27

causes this (log file attached)

MBPro:~ me$ sudo port install qtiplot +qtexengine +python27
--->  Computing dependencies for qtiplot
--->  Fetching archive for qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://packages.macports.org/qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/qtiplot
--->  Fetching distfiles for qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://sea.us.distfiles.macports.org/macports/distfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://lil.fr.distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://cjj.kr.distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://nue.de.distfiles.macports.org/macports/distfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://download.berlios.de/qtiplot/
--->  Verifying checksums for qtiplot
Error: Checksum (rmd160) mismatch for QTeXEngine-0.3-opensource.zip
Error: Checksum (sha256) mismatch for QTeXEngine-0.3-opensource.zip
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
The file has been moved to: /opt/local/var/macports/distfiles/qtiplot/QTeXEngine-0.3-opensource.zip.html
Error: org.macports.checksum for port qtiplot returned: Unable to verify file checksums
Please see the log file for port qtiplot for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qtiplot/qtiplot/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qtiplot failed

Attachments (1)

main.log (50.9 KB) - added by other@… 5 years ago.
Indicated log file, main.log

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by other@…

Attachment: main.log added

Indicated log file, main.log

comment:1 Changed 5 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Owner: changed from macports-tickets@… to nicos@…

Please use WikiFormatting and preview your post when using Trac. When reporting bugs against ports, please Cc the maintainer.

The problem seems to be berlios in this case.

comment:2 Changed 5 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: newclosed

comment:3 in reply to:  2 Changed 5 years ago by other@…

Replying to cal@…:

r121736.

Sorry if I’m missing something, but I’m still getting the same problem, after

sudo port clean qtiplot

then attempting to re-install,

sudo port install qtiplot +qtexengine +python27

still gives this:

MBPro:~ me$ sudo port install qtiplot +qtexengine +python27
--->  Computing dependencies for qtiplot
--->  Fetching archive for qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://packages.macports.org/qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/qtiplot
--->  Fetching distfiles for qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://sea.us.distfiles.macports.org/macports/distfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://lil.fr.distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://nue.de.distfiles.macports.org/macports/distfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://download.berlios.de/qtiplot/
--->  Verifying checksums for qtiplot
Error: Checksum (rmd160) mismatch for QTeXEngine-0.3-opensource.zip
Error: Checksum (sha256) mismatch for QTeXEngine-0.3-opensource.zip
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
The file has been moved to: /opt/local/var/macports/distfiles/qtiplot/QTeXEngine-0.3-opensource.zip.html
Error: org.macports.checksum for port qtiplot returned: Unable to verify file checksums
Please see the log file for port qtiplot for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qtiplot/qtiplot/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qtiplot failed


    

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Run sudo port selfupdate followed by sudo port clean --all qtiplot. Then try again.

comment:5 Changed 5 years ago by other@…

Thanks for that tip. Maybe a tweak to the docs at some point?

Anyway, here’s what happened. Different but still a problem.

Jerry

MBPro:~ me$ sudo port selfupdate
Password:
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.3.1 installed,
MacPorts base version 2.3.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
MBPro:~ me$ sudo port clean --all qtiplot
--->  Cleaning qtiplot
MBPro:~ me$ sudo port install qtiplot +qtexengine +python27
--->  Computing dependencies for dbus
--->  Fetching archive for dbus
--->  Attempting to fetch dbus-1.8.6_0.darwin_13.x86_64.tbz2 from http://packages.macports.org/dbus
--->  Attempting to fetch dbus-1.8.6_0.darwin_13.x86_64.tbz2.rmd160 from http://packages.macports.org/dbus
--->  Installing dbus @1.8.6_0
--->  Cleaning dbus
--->  Computing dependencies for dbus
--->  Deactivating dbus @1.8.2_0
--->  Cleaning dbus
--->  Activating dbus @1.8.6_0

############################################################################
# Startup items have been generated that will aid in
# starting dbus with launchd. They are disabled
# by default. Execute the following commands to start them,
# and to cause them to launch at startup:
#
# sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist
# launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
############################################################################

--->  Cleaning dbus
--->  Computing dependencies for gettext
--->  Fetching archive for gettext
--->  Attempting to fetch gettext-0.19.1_1.darwin_13.x86_64.tbz2 from http://packages.macports.org/gettext
--->  Attempting to fetch gettext-0.19.1_1.darwin_13.x86_64.tbz2.rmd160 from http://packages.macports.org/gettext
--->  Installing gettext @0.19.1_1
--->  Cleaning gettext
--->  Computing dependencies for gettext
--->  Deactivating gettext @0.19.1_0
--->  Cleaning gettext
--->  Activating gettext @0.19.1_1
--->  Cleaning gettext
--->  Computing dependencies for qtiplot
--->  Fetching archive for qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://packages.macports.org/qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9_9+python27+qtexengine.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/qtiplot
--->  Fetching distfiles for qtiplot
--->  Attempting to fetch qtiplot-0.9.8.9.tar.bz2 from http://distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://distfiles.macports.org/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://sea.us.distfiles.macports.org/macports/distfiles/qtiplot
--->  Attempting to fetch QTeXEngine-0.3-opensource.zip from http://softlayer-dal.dl.sourceforge.net/qtiplot.berlios
--->  Verifying checksums for qtiplot                                                
--->  Extracting qtiplot
--->  Applying patches to qtiplot
--->  Configuring qtiplot
Error: org.macports.configure for port qtiplot returned: error copying "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qtiplot/qtiplot/work/QTeXEngine": no such file or directory
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qtiplot failed
MBPro:~ me$ 

comment:6 Changed 5 years ago by NicosPavlov

Reverting part of r121736 to still use zip packages, as QTeXEngine is only distributed in this form in r121806.

comment:7 Changed 5 years ago by other@…

Qtiplot now installs without problems. Many thanks!

Note: See TracTickets for help on using tickets.