Opened 9 years ago

Closed 8 years ago

#44454 closed defect (duplicate)

p5-eperl: build failure

Reported by: mojca (Mojca Miklavec) Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cfaerber@…, dimkab
Port: p5-eperl

Description

When compiling wml, p5.16-eperl turned out to be broken.

See:

In file included from eperl_perl5.c:38:
./eperl_perl5.h:76:11: warning: 'PL_defoutgv' macro redefined
#  define PL_defoutgv defoutgv
          ^
/opt/local/lib/perl5/5.16.3/darwin-thread-multi-2level/CORE/embedvar.h:149:9: note: previous definition is here
#define PL_defoutgv             (vTHX->Idefoutgv)
        ^
eperl_perl5.c:84:19: error: use of undeclared identifier 'defoutgv'
    IoFLAGS(GvIOp(PL_defoutgv)) |= IOf_FLUSH; /* $|=1 */
                  ^

Change History (4)

comment:1 Changed 8 years ago by dimkab

Cc: dima.batenkov@… added

Cc Me!

comment:2 Changed 8 years ago by mf2k (Frank Schima)

Port: wml removed

I see this too.

comment:3 Changed 8 years ago by cfaerber@…

This is a duplicate of #44447, where a patch is attached.

comment:4 Changed 8 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.