Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#45530 closed defect (duplicate)

Pymol @1.7.1.1on Yosemite

Reported by: sean.connell@… Owned by: howarth@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: radaroutthere@…, iaindhay@…
Port: pymol

Description (last modified by ryandesign (Ryan Schmidt))

Hello I am have problems running pymol @1.7.1.1 under Mac OS X 10.10. I was first using a version that worked under OS X 10.9 but after the upgrade it failed with this error:

 Detected OpenGL version 2.0 or greater. Shaders available.
 Detected GLSL version 1.20.
 OpenGL graphics engine:
  GL_VENDOR:   NVIDIA Corporation
  GL_RENDERER: NVIDIA GeForce GT 750M OpenGL Engine
  GL_VERSION:  2.1 NVIDIA-10.0.43 310.41.05f01
Mac OS X 10.10000 or later required !
Abort trap: 6

Then following the instructions on mac port I tried to remove and reinstall pymol with:

sudo port uninstall pymol
sudo port install pymol

and now the installation files with:

Error: org.macports.destroot for port pymol returned: error copying "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_pymol/pymol/work/pymol/setup/pymol_macports" to "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_pymol/pymol/work/destroot/opt/local/bin/pymol": file already exists

Change History (11)

comment:1 Changed 7 years ago by sean.connell@…

Cc: sean.connell@… added

Cc Me!

comment:2 Changed 7 years ago by radaroutthere@…

Hi. I think I know the cause of the abort trap problem.

Two seconds of searching seems to indicate that PyMOL uses Tkinter. A bug has recently been filed in Tk for Yosemite - http://core.tcl.tk/tk/info/1d37c3e16616a0e6283ef390272f0cf483b74b5f - which produces the same error.

While I feel the pain of this problem, I'm not sure how it can be solved. If it's a problem in Tk itself, then it may be outside the scope of MacPorts. Hoping that someone else can provide a suggestion or hope of a solution.

comment:3 Changed 7 years ago by radaroutthere@…

Cc: radaroutthere@… added

Cc Me!

comment:4 Changed 7 years ago by radaroutthere@…

Turns out that the Tk bug was filed in relation to MacPorts ticket #45444

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: sean.connell@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to howarth@…
Port: @1.7.1.1 removed

The reason why you get an error copying is presumably that you did not run "sudo port clean pymol" before trying to install it.

comment:6 Changed 7 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Let’s call this a duplicate of #45444 then.

comment:7 Changed 7 years ago by mtiberti (Matteo Tiberti)

Sorry but I don't think this is really solved; I tried updating tk to the latest supposedly fixed version:

$ sudo port info tk
tk @8.6.1_2 (x11)

then clean and install:

$ sudo port selfupdate; sudo port clean pymol; sudo port install pymol
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.3.2 installed,
MacPorts base version 2.3.2 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
--->  Cleaning pymol
--->  Computing dependencies for pymol
--->  Fetching archive for pymol
--->  Attempting to fetch pymol-1.7.1.0_0.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/pymol
--->  Attempting to fetch pymol-1.7.1.0_0.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/pymol
--->  Attempting to fetch pymol-1.7.1.0_0.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/pymol
--->  Fetching distfiles for pymol
--->  Staging pymol into destroot
Error: org.macports.destroot for port pymol returned: error copying "/opt/local/var/macports/build/_Users_user_devel_ports_science_pymol/pymol/work/pymol/setup/pymol_macports" to "/opt/local/var/macports/build/_Users_user_devel_ports_science_pymol/pymol/work/destroot/opt/local/bin/pymol": file already exists

am I doing something wrong?

Last edited 7 years ago by mtiberti (Matteo Tiberti) (previous) (diff)

comment:8 Changed 7 years ago by iaindhay@…

Cc: iaindhay@… added

Cc Me!

comment:9 Changed 7 years ago by mtiberti (Matteo Tiberti)

Care to help with this? I'm most probably not the only one still having this problem. Thanks!

comment:10 Changed 7 years ago by larryv (Lawrence Velázquez)

This is a different problem, for which #45401 is already open. Let’s keep this ticket closed.

comment:11 Changed 7 years ago by mtiberti (Matteo Tiberti)

oh, sorry, I hadn't noticed. Thanks for Cc-ing me!w

Version 0, edited 7 years ago by mtiberti (Matteo Tiberti) (next)
Note: See TracTickets for help on using tickets.