Opened 7 years ago

Closed 6 years ago

#45638 closed defect (invalid)

MacVim @7.4.snapshot73_0: build failure

Reported by: markph0204@… Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc:
Port: MacVim

Description

Fails to build with command:

sudo port install macvim

I have cleaned, installed ports fresh, and attempted to execute with -huge variant applied.

Yosemite Mac OS - all updates applied

xcode-select version 2339.

build tools: Xcode 6.1 Build version 6A1052d

Attachments (2)

main.log (154.2 KB) - added by markph0204@… 7 years ago.
main.2.log (157.7 KB) - added by markph0204@… 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by markph0204@…

Attachment: main.log added

comment:1 Changed 7 years ago by markph0204@…

Source fetch from: MacVim-7.4.snapshot73_0+huge.darwin_14.x86_64.tbz2

comment:2 Changed 7 years ago by larryv (Lawrence Velázquez)

Keywords: macvim removed
Owner: changed from macports-tickets@… to raimue@…
Port: MacVim added
Summary: MacVim 7.4 snapshot 73 will not build successfullyMacVim @7.4.snapshot73_0: build failure

For what it’s worth, I’ve had MacVim @7.4.snapshot73_0+huge installed from source ever since upgrading to Yosemite.

comment:3 Changed 7 years ago by raimue (Rainer Müller)

The problem in your main.log is:

:info:build /opt/local/var/macports/build/.../MacVim/work/MacVim/src/MacVim/MMWindowController.m:75:9: fatal error: 'PSMTabBarControl/PSMTabBarControl.h' file not found

I can't reproduce this problem, MacVim @7.4.snapshot73_0+huge builds fine here. I even tried this with various different variants, using either +huge or -huge does not trigger any build problem for me.

Could you please run sudo port clean MacVim and then try again?

comment:4 Changed 7 years ago by markph0204@…

Ran....

sudo port selfupdate
sudo port clean macvim
sudo port install macvim

Output from last command...

--->  Computing dependencies for MacVim
--->  Fetching archive for MacVim
--->  Attempting to fetch MacVim-7.4.snapshot73_0+huge.darwin_14.x86_64.tbz2 from http://packages.macports.org/MacVim
--->  Attempting to fetch MacVim-7.4.snapshot73_0+huge.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/MacVim
--->  Attempting to fetch MacVim-7.4.snapshot73_0+huge.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/MacVim
--->  Fetching distfiles for MacVim
--->  Verifying checksums for MacVim
--->  Extracting MacVim
--->  Applying patches to MacVim
--->  Configuring MacVim
--->  Building MacVim
Error: org.macports.build for port MacVim returned: command execution failed
Please see the log file for port MacVim for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_editors_MacVim/MacVim/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port macvim failed

New Log attached.

I'm doing some more digging... I may have found something...

Changed 7 years ago by markph0204@…

Attachment: main.2.log added

comment:5 Changed 6 years ago by markph0204@…

Please close the defect. It has been resolved. It was my toolchain. I completely removed and re-installed Xcode and tools, and things are working.

For anyone else...

I attempted to fetch the port and using make, built it outside of using port, and it was building fine. After unable to determine what was really broken - I decide to reinstall the tools fresh and reboot.

Sorry for the trouble.

comment:6 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.