Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#46250 closed enhancement (fixed)

netcdf does not install netcdf_par.h

Reported by: patrick.widener@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: petrrr
Port: netcdf

Description

The netcdf port does not install the file netcdf_par.h, available in the NetCDF distribution as include/netcdf_par.h and required for performing parallel NetCDF I/O.

Change History (12)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Keywords: netcdf parallel netcdf_par removed
Owner: changed from macports-tickets@… to takeshi@…
Version: 2.3.3

In the future, please Cc the port maintainers (port info --maintainers netcdf), if any.

comment:2 Changed 6 years ago by seanfarley (Sean Farley)

Almost certainly, this is because no MPI variant was selected. See 'port variants netcdf'.

comment:3 Changed 6 years ago by patrick.widener@…

Sorry, for me this occurs when using each of +openmpi, +mpich, +mpich_devel, +openmpi_devel, and +netcdf4.

comment:4 Changed 6 years ago by seanfarley (Sean Farley)

Sorry for the quick dismissal. If takeshi doesn't get to it soon, I'll try to take a look.

comment:5 in reply to:  4 Changed 6 years ago by patrick.widener@…

Replying to sean@…:

Sorry for the quick dismissal. If takeshi doesn't get to it soon, I'll try to take a look.

No worries, not selecting an MPI variant was the first thing I thought of too. I should have put that info in the ticket.

comment:6 Changed 6 years ago by tenomoto (Takeshi Enomoto)

Sorry for slow response. I was able to install netcdf_par.h with hdf5 @1.8.13_0+cxx+mpich. See http://www.unidata.ucar.edu/software/netcdf/docs/build_parallel.html

comment:7 Changed 6 years ago by patrick.widener@…

Oops. I thought I had hdf5 +mpich selected but I did not. Reinstalling HDF5 as described and reinstalling netcdf does the trick. Thanks!

comment:8 Changed 6 years ago by seanfarley (Sean Farley)

Takeshi, I just checked the netcdf portfile and it seems you commented out the mpi.enforce_variant line. That would have prevented this kind of error from happening. I just tested the note in the comment and couldn't reproduce what you wrote. Is there something I'm missing? I tried a few combinations and it seems to work as expected so I would like to re-enable it.

comment:9 Changed 6 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:10 Changed 6 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: newclosed

I went ahead and re-enabled the mpi check in r130203. If that doesn't work, Takeshi, let me know because that would mean a bug in the mpi portgroup.

comment:11 Changed 6 years ago by tenomoto (Takeshi Enomoto)

Sean, I'm on vacation with slow connection. I have no problem at this time with re-enabling mpi.enforce_variant. I appreciate you committed the r130203.

comment:12 in reply to:  11 Changed 6 years ago by seanfarley (Sean Farley)

Replying to takeshi@…:

Sean, I'm on vacation with slow connection. I have no problem at this time with re-enabling mpi.enforce_variant. I appreciate you committed the r130203.

No worries about the time; I am slow myself ;-) Thanks for the response!

Note: See TracTickets for help on using tickets.