Opened 6 years ago

Closed 6 years ago

#46798 closed defect (fixed)

kdenlive: DV module, QImage, Title module disabled

Reported by: hemant_verma2000@… Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ddennedy (Dan Dennedy)
Port: kdenlive, mlt

Description

Hi,

I recently installed kdenlive on OS X Yesomite 10.10.2. It installed successfully. However, DV module, QImage and Title modules are disabled in the config wizard and I believe, because of that I'm facing the following issues on the "Add title" window:

  1. 'Ok' button is always disabled. Only 'Cancel' is enabled. So I can't add a title clip.
  2. When I click on colour section, the colour palette doesn't appear.

melt: 0.9.2

Qt: 4.8.6

KDE Development Platform: 4.14.3

kde4-config: 1.0

Anyone else has faced similar issues?

Thanks

Attachments (2)

mlt-0.9.2-Portfile-qt4.diff (810 bytes) - added by ddennedy (Dan Dennedy) 6 years ago.
Fix qt4-mac dependency
mlt-0.9.6-Portfile.diff (1.7 KB) - added by ddennedy (Dan Dennedy) 6 years ago.
Upgrade MLT to v0.9.6, fix qt module, drop libdv dependency, add libexif dependency.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mk@…
Port: kdenlive added
Summary: DV module, QImage, Title module disabledkdenlive: DV module, QImage, Title module disabled

comment:2 Changed 6 years ago by mkae (Marko Käning)

Do you mean with "Add title" window actually the "Title Clip" window (which can be reached through "Add title clip")?

In there at least I do see an enabled 'OK' button!

Well, but there is no colour selection, so I conclude that I am not checking at the correct place.

Please give more information how to reproduce what you've found.

(I have only very basic knowledge of kdenlive's workflows!)

comment:3 Changed 6 years ago by jeff@…

I can confirm the original poster's experience:

In yosemite 10.10.2, I just installed, via MacPorts, Kdenlive version 0.9.10 using KDE Development Platform 4.14.3. (A year ago or so, I had installed and then uninstalled Kdenlive. I don't know if that might have any effect.) I followed the procedure described at https://kdenlive.org/download-mac.

When I launched Kdenlive, the config wizard appeared. Under Installed modules, it reports missing or disabled DV module (libdv), Image module, and Title module.

Project > Add Title Clip opens the Title Clip window, but the OK button is disabled, and I've not found any way to enable it.

comment:4 Changed 6 years ago by mkae (Marko Käning)

Version: 2.3.3

OK, herewith I can verify that after a rebuild of the application on 10.9.5 I DO see the same symptoms. :(

I have no idea how to fix this and I suggest to contact upstream for further advice.

comment:5 Changed 6 years ago by billy@…

confirmed on a clean install of macports and kdenlive. The kdenlive board reports the issue being a broken (misconfigured) MLT build, missing QImage and kdenlivetitle modules. (see https://kdenlive.org/forum/adding-title-clip-ok-button-greyed-out-cant-add )

port install libdv and port install mlt both report all is well.

comment:6 in reply to:  5 Changed 6 years ago by mkae (Marko Käning)

Cc: dan@… added
Port: mlt added

Replying to billy@…:

... missing QImage and kdenlivetitle modules. (see https://kdenlive.org/forum/adding-title-clip-ok-button-greyed-out-cant-add )

yes, indeed, those are missing!

Dan, do you have a clue regarding MLT? Are you still maintaining this port?

Last edited 6 years ago by mkae (Marko Käning) (previous) (diff)

comment:7 Changed 6 years ago by ddennedy (Dan Dennedy)

Yes, I am still maintaining MLT port, but not kdenlive. The DV module is not required for Kdenlive even though it has a check for it; I don't know why. DV module is very rarely needed. While MLT does not have a hard dependency on Qt, it is pretty needed by Kdenlive. MLT portfile change r72609, removed the qt4-mac dependency and added the qt4 PortGroup. I think that adds the dependency in a different way. If that does not work anymore, then I do not know why. Is the problem that the dependency is not existing and qt4 not installing before mlt? It will take me a while to update macports on my system to test this against something current.

comment:8 Changed 6 years ago by ddennedy (Dan Dennedy)

I see the problem. qt_libs_dir needs to be changed to qt_frameworks_dir, but I am having trouble getting port to read my local Portfile changes (after running portindex) in order to fully test this. I don't know why, and frankly I am getting tired of trying to figure out why.

comment:9 in reply to:  8 Changed 6 years ago by mkae (Marko Käning)

Replying to dan@…:

qt_libs_dir needs to be changed to qt_frameworks_dir

OK, I will check that out and report back.

Thanks for caring, Dan! :-D

comment:10 Changed 6 years ago by ddennedy (Dan Dennedy)

After giving up on my local ports Portfile, I edited the Portfile in the synced tree, but changing qt_libs_dir to qt_frameworks_dir did not work. Neither did removing --qimage-libdir and --qimage-includedir to rely upon pkg-config. Meanwhile, both approaches are working for me at the command line outside of MacPorts (cd ~/src/mlt; ./configure... against macports-installed dependencies). Still trying to figure this out.

Changed 6 years ago by ddennedy (Dan Dennedy)

Attachment: mlt-0.9.2-Portfile-qt4.diff added

Fix qt4-mac dependency

comment:11 Changed 6 years ago by ddennedy (Dan Dennedy)

I solved this and attached a patch for the mlt Portfile. Not only is qt_frameworks_dir needed, but the name of the MLT module changed from qimage to qt in this version of MLT, which required changing the name of the configure args.

comment:12 Changed 6 years ago by ddennedy (Dan Dennedy)

Also, the DV module in MLT is deprecated and no longer available as part of the normal MLT build process. Like I said, it is not needed if you have the avformat (ffmpeg) module.

Changed 6 years ago by ddennedy (Dan Dennedy)

Attachment: mlt-0.9.6-Portfile.diff added

Upgrade MLT to v0.9.6, fix qt module, drop libdv dependency, add libexif dependency.

comment:13 Changed 6 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Thanks, Dan, I've committed your mlt patch in #47513.

Note: See TracTickets for help on using tickets.