Opened 3 years ago

Last modified 2 years ago

#46917 new defect

Atlas does not produce threaded libraries on Yosemite

Reported by: urilabob@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: atlas

Description (last modified by larryv (Lawrence Velázquez))

This reads almost like a direct resurrection of ticket #35683 and ticket #35594. In a new install of MacPorts, attempting to install octave eventually leads to an attempt to install qrupdate, which fails with

:info:build             -L/opt/local/lib -ltatlas -L/opt/local/lib -llapack
:info:build ld: library not found for -ltatlas
:info:build collect2: error: ld returned 1 exit status
:info:build make[1]: *** [../libqrupdate.dylib] Error 1

(I originally encountered the same problem using the restore_ports script, so decided to do a clean install)

Following the reasoning of ticket 35594, I have run port -v configure atlas, which produced the attached output.

Change History (2)

comment:1 Changed 3 years ago by larryv (Lawrence Velázquez)

  • Description modified (diff)
  • Keywords atlas threaded library removed
  • Owner changed from macports-tickets@… to vince@…

In future tickets, please Cc relevant port maintainers (port info --maintainers atlas).

comment:2 Changed 2 years ago by Veence (Vincent)

That’s strange. Threaded libraries should be produced by default. Did you manage to find out what was wrong, or do you still have the same problem?

Also, I don’t see your output from ‘port -v configure’.

Note: See TracTickets for help on using tickets.