Opened 6 years ago

Closed 6 years ago

#46925 closed defect (invalid)

requires version 13.0.0, but libjpeg.8.dylib provides version 9.0.0

Reported by: divisabella@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: libjpeg-turbo

Description (last modified by neverpanic (Clemens Lang))

I am using Macports to install libjpeg 8, which I need for a MATLAB program, the Berkeley Segmentation Engine that I am using for school, but when I try to run the example, I receive the following:

Invalid MEX-file '/Users/isabella/Desktop/BSR/grouping/lib/mex_pb_parts_final_selected.mexmaci64':
dlopen(/Users/isabella/Desktop/BSR/grouping/lib/mex_pb_parts_final_selected.mexmaci64, 6): Library
not loaded: /opt/local/lib/libjpeg.8.dylib

  Referenced from: /Users/isabella/Desktop/BSR/grouping/lib/mex_pb_parts_final_selected.mexmaci64
  Reason: Incompatible library version: mex_pb_parts_final_selected.mexmaci64 requires version 13.0.0
  or later, but libjpeg.8.dylib provides version 9.0.0

I don't have any experience changing MEX files, but I've tried all kinds of things with my libjpeg installation, between homebrew and macports, but I haven't had any success. Please help!

Change History (2)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Priority: HighNormal

Please do not set the Priority field because it is for use by Macports team members only.

comment:2 Changed 6 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Keywords: libjpeg-turbo libjpeg removed
Resolution: invalid
Status: newclosed
Type: requestdefect

The problem is that MATLAB internally sets DYLD_LIBRARY_PATH while its running and keeps it in the environment you use to load the library. Unset DYLD_LIBRARY_PATH before loading your library and it should work. DYLD_LIBRARY_PATH should never ever be set in production software, and it's a mistake made by the MATLAB developers that it does. You should contact them and ask them to link their libraries correctly on OS X so they don't need to set it.

Note: See TracTickets for help on using tickets.