Opened 4 years ago

Closed 22 months ago

#46930 closed defect (invalid)

Error: Failed to install libcomerr

Reported by: ravi.retheesh@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: libcomerr

Description (last modified by neverpanic (Clemens Lang))

When trying to install the MacPorts, below error is what am receiving.

In the variants.conf file, i have kept the option as +universal (/opt/local/etc/macports/variants.conf) there is no specific deployment target given in the /opt/local/etc/macports/macports.conf

The entire log file at the time of error is also attached. Please help to resolve this issue.

--->  Computing dependencies for openldap
--->  Dependencies to be installed: cyrus-sasl2 kerberos5 libcomerr db46 icu tcp_wrappers
--->  Staging libcomerr into destroot
Error: org.macports.destroot for port libcomerr returned: 
Error: Failed to install libcomerr
Please see the log file for port libcomerr for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_e2fsprogs/libcomerr/main.log
Error: The following dependencies were not installed: cyrus-sasl2 kerberos5 libcomerr db46 icu tcp_wrappers
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port openldap failed

Attachments (1)

main.log (5.4 KB) - added by ravi.retheesh@… 4 years ago.
Error while building libcomerr

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by ravi.retheesh@…

Attachment: main.log added

Error while building libcomerr

comment:1 Changed 4 years ago by ravi.retheesh@…

The port installation was attempted on a Yosemite machine 10.10.1.

Total number of port attempted to be installed were below

sudo port install automake autoconf libtool pkgconfig intltool wget cunit antlr3 speex libvpx readline sqlite3 libsoup openldap libupnp ffmpeg-devel -gpl2

comment:2 Changed 4 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Port: libcomerr added

Please use WikiFormatting and preview your post in trac. When reporting bugs against ports, please fill in the port field and Cc the maintainer, if any, as explained in our Ticket Guidelines prominently linked from the new ticket page.

comment:3 Changed 4 years ago by neverpanic (Clemens Lang)

Resolution: invalid
Status: newclosed

Your logfile contains "skipping completed" and is thus not a clean attempt. This means you did not follow wiki:FAQ#buildfails.

The problem is

:info:destroot dyld: lazy symbol binding failed: Symbol not found: _map_fd
:info:destroot   Referenced from: /usr/bin/install_name_tool
:info:destroot   Expected in: /usr/lib/libSystem.B.dylib
:info:destroot
:info:destroot dyld: Symbol not found: _map_fd
:info:destroot   Referenced from: /usr/bin/install_name_tool
:info:destroot   Expected in: /usr/lib/libSystem.B.dylib

Your /usr/bin/install_name_tool is broken. I don't know how you managed to do that, but please make sure you do not have any DYLD_* variables in your environment and re-install the command line tools or Xcode. Additionally, I don't even know what the missing _map_fd symbol should be, as I don't have it in my libSystem (or any other library in /usr/lib/system for that matter), and my /usr/bin/install_name_tool does not reference it either.

Anyway, this is clearly an issue with your local configuration and not with MacPorts.

comment:4 Changed 22 months ago by cosmicad

Resolution: invalid
Status: closedreopened

can u pls explain the solution...in details step by step...

Last edited 22 months ago by cosmicad (previous) (diff)

comment:5 Changed 22 months ago by mf2k (Frank Schima)

Resolution: invalid
Status: reopenedclosed

Please do not re-open old tickets. Trac is not for tech support. Follow-up on the Macports-Users mailing list instead.

Note: See TracTickets for help on using tickets.