Opened 6 years ago

Closed 6 years ago

#47310 closed defect (worksforme)

inkscape 0.91 fails to load images; throws gdk-pixbuf assertion error

Reported by: ccarter@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: su-v
Port: inkscape

Description (last modified by mf2k (Frank Schima))

This is an update to ticket:45747.

The problem with failing loading images still exists.

I am now using OSX 10.10.2 And I have inkscape@0.91 I've perform a complete reinstall of maports (currently MacPorts 2.3.3) I've attempted to try loading images with gtk-pixbuf and gtk-pixbuf2 installed.

I get these as error/warning messages:

** Message: Gdk::PixbufError in SVGPreview::showImage
(inkscape:86820): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed
(inkscape:86820): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

Change History (12)

comment:1 Changed 6 years ago by ccarter@…

Correction. That should be with:

gtk-pixbuf OR gtk-pixbuf2 installed

not both.

comment:2 Changed 6 years ago by su-v

Cc: suv-sf@… added

Cc Me!

comment:3 Changed 6 years ago by mf2k (Frank Schima)

Keywords: inkscape gtk2 removed
Owner: changed from macports-tickets@… to devans@…
Port: inkscape added; inkscape@0.91 removed

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers inkscape), if any.

comment:4 Changed 6 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:5 in reply to:  1 Changed 6 years ago by dbevans (David B. Evans)

Replying to ccarter@…:

Correction. That should be with:

gtk-pixbuf OR gtk-pixbuf2 installed

not both.

I think you mean gdk-pixbuf2 which is the correct dependency. gdk-pixbuf is an old outdated port (gnome 1.x era).

comment:6 Changed 6 years ago by dbevans (David B. Evans)

Status: newassigned

comment:7 Changed 6 years ago by dbevans (David B. Evans)

On 4/1/15 9:28 AM, W Craig Carter wrote:

Thank you devans,

I am not sure what the etiquette is on this mail-list regarding responding to poster; sorry if I am breaking etiquette.

Yes, that's correct--my mistake. I have

gdk-pixbuf2 @2.31.3_0+x11 (active)

right now.

The images are still not loading. I am curious if I am the only one having this difficulty.

Kind regards, Craig

Best to respond by adding comments to the trac ticket rather than by email. This keeps a history of our interactions. I will test this morning and let you know what I find.

Thanks for your report.

comment:8 Changed 6 years ago by dbevans (David B. Evans)

I can't reproduce this problem on either Mavericks or Yosemite. Both JPEG and PNG images load without error using either File->Open or File->Import. This is using the default selections in the resulting bitmap image import dialog and the default X11 build

$ port installed inkscape
The following ports are currently installed:
  inkscape @0.91_2+strict+x11 (active)

Is this the version you are using?

comment:9 in reply to:  8 ; Changed 6 years ago by ccarter@…

Replying to devans@…:

I can't reproduce this problem on either Mavericks or Yosemite. Both JPEG and PNG images load without error using either File->Open or File->Import. This is using the default selections in the resulting bitmap image import dialog and the default X11 build

$ port installed inkscape
The following ports are currently installed:
  inkscape @0.91_2+strict+x11 (active)

Is this the version you are using?

Thanks, yes:

port installed | grep ink

gives: inkscape @0.91_2+strict+x11 (active)

inkscape-textext @0.4.4_2+pygtk+python27 (active)

I'm a newbie at ports, I am trying to find a way to construct a list of all dependencies of inkscape so that I can construct a list of versions.

Any guesses what is going wrong on my system?

Thanks for the help, Craig

comment:10 in reply to:  9 Changed 6 years ago by dbevans (David B. Evans)

Replying to ccarter@…:

I'm a newbie at ports, I am trying to find a way to construct a list of all dependencies of inkscape so that I can construct a list of versions.

If you want a name sorted list of installed ports and versions that are recursive dependencies of inkscape

port installed rdepof:inkscape

will do it but I don't think that will be much help.

First make sure you have done everything in the wiki:Migration instructions

If that is all done, to make sure everything is updated to the latest versions you can do this (part of the Migration instructions really)

sudo port selfupdate (update the list of ports to the latest version)
sudo port outdated  (see which ports are outdated)
sudo port upgrade outdated (go ahead and upgrade the outdated ports)

Any guesses what is going wrong on my system?

Since I can't reproduce the problem, I'm guessing it's some problem in upgrading your MacPorts installation to Yosemite. Certainly something about your installation that is different than mine. Beyond that, it's hard to say.

Thanks for the help, Craig

No problem, I'm sorry I can't be of more help.

comment:11 Changed 6 years ago by ccarter@…

OK, thanks. I just did the selfupdate through upgrade outdated (which included only glib2 2.42.2_0 < 2.44.0_0 gnutls 3.3.13_0 < 3.3.14_0 )

And images still don't load.

If you can't reproduce, then it is impossible to debug and this ticket should close... sigh.

I am going to uninstall all of macports again, and then install from scratch. I'll report back on whether this fixes it or not.

Sorry for the hassle, but thanks, WCC

comment:12 Changed 6 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: assignedclosed

OK, closing as "works for me", but please let us know if you are able to resolve the problem or find something more concrete to go on.

Note: See TracTickets for help on using tickets.