Opened 6 years ago

Closed 4 years ago

#47533 closed defect (fixed)

unison @2.48.3 Does not build on Tiger

Reported by: csanchezdll Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: tiger haspatch Cc: kurthindenburg (Kurt Hindenburg)
Port: unison

Description

Build fails because Makefile.OCaml specifies 10.5 as minimum OS X version [macos-version-min compiler parameter is documented as minimum version the build binary is supposed to be run on]. Attached patches lower this (only on Tiger).

Attachments (2)

Portfile.diff (418 bytes) - added by csanchezdll 6 years ago.
patch-Makefile.OCaml-MINOSXVERSION.diff (314 bytes) - added by csanchezdll 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by csanchezdll

Attachment: Portfile.diff added

Changed 6 years ago by csanchezdll

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Keywords: tiger, haspatchtiger haspatch

comment:2 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added
Resolution: fixed
Status: newclosed

I went ahead and used your patches when I updated to latest release

r153746

Note: See TracTickets for help on using tickets.