Opened 5 years ago

Closed 5 years ago

#47562 closed enhancement (fixed)

MacPorts - nano - lost compiler option --enable-nanorc

Reported by: vit0rg Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: nano

Description

I've found that port for nano has no compiler option "--enable-nanorc". The problem is that nano can't use it's configuration files /etc/nanorc and ~/.nanorc without this option.

The funny thing is that port contains note "A sample configuration file is available at /opt/local/share/doc/nano/nanorc.sample." - but it useless as long as nano compiled without nanorc support.

Please add --enable-nanorc to port's configure.args or create additional variant for port with nanorc support. Thanks.

Change History (2)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Keywords: nano nanorc removed
Version: 2.3.3

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.