Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#47758 closed defect (fixed)

gdal upgrade to 1.11.2_2 fails

Reported by: watsodw Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: basmac, florian@…, cmutel (Chris Mutel), chris.waigl@…, hanfl@…, larryv (Lawrence Velázquez), gbesanaostman@…
Port: gdal

Description

See log.

Attachments (1)

main.log (2.8 MB) - added by watsodw 5 years ago.

Change History (20)

Changed 5 years ago by watsodw

Attachment: main.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: vince@… removed
Owner: changed from macports-tickets@… to vince@…

comment:2 Changed 5 years ago by basmac

Cc: barry.j.mcinnes@… added

Cc Me!

comment:3 Changed 5 years ago by florian@…

Cc: florian@… added

Cc Me!

comment:4 Changed 5 years ago by florian@…

I can confirm this on OSX 10.9 only using Apple LLVM version 6.0 (clang-600.0.54):

Undefined symbols for architecture x86_64:
  "std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >::find_last_of(char const*, unsigned long) const", referenced from:
      HDF5Dataset::HDF5ReadDoubleAttr(char const*, double**, int*) in hdf5dataset.o

Builds fine without the hdf5 variant. No issues with hdf5 using gcc on OSX 10.6.

comment:5 Changed 5 years ago by cmutel (Chris Mutel)

Cc: cmutel@… added

Cc Me!

comment:6 Changed 5 years ago by chris.waigl@…

Cc: chris.waigl@… added

Cc Me!

comment:7 Changed 5 years ago by hanfl@…

Cc: hanfl@… added

Cc Me!

comment:12 Changed 5 years ago by Veence (Vincent)

I’m not sure I can do something about it. I have no 10.9 system anymore. If someone finds a workaround or even a kludge, I will gladly pull it, but as is, it’s a bit way over my head (besides I gave up C++ so long ago that most of it now sounds like mumbo jumbo to me. :(

Isn’t that tied to some buggy release of the STDC++ library?

Last edited 5 years ago by Veence (Vincent) (previous) (diff)

comment:13 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:14 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: gbesanaostman@… added

Has duplicate #47925.

comment:15 Changed 5 years ago by larryv (Lawrence Velázquez)

I can reproduce this on Yosemite.

comment:16 in reply to:  15 Changed 5 years ago by florian@…

I know of another person who can reproduce this failure on 10.10.3.

Last edited 5 years ago by florian@… (previous) (diff)

comment:17 Changed 5 years ago by gbesanaostman@…

Yes, I forgot to put this info in my ticket. I was installing port gdal on Yosemite 10.10.3 when it failed. I hope someone can come up with a solution, soon. Thanks a lot in advance!

comment:18 Changed 5 years ago by florian@…

This GDAL build failure seems to be solved by an upstream patch to HDF5 (r137065, https://www.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8.15-patch1/src/hdf5-1.8.15-patch1-RELEASE.txt for reference). Can anyone confirm this?

comment:19 Changed 5 years ago by basmac

Works for me now -

bash-3.2# port clean gdal

---> Cleaning gdal

bash-3.2# port install gdal +expat+geos+hdf5+netcdf+spatialite

---> Computing dependencies for gdal

---> Fetching archive for gdal

---> Attempting to fetch gdal-1.11.2_2+expat+geos+hdf5+netcdf+spatialite.darwin_14.x86_64.tbz2 from http://packages.macports.org/gdal

---> Attempting to fetch gdal-1.11.2_2+expat+geos+hdf5+netcdf+spatialite.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/gdal

---> Attempting to fetch gdal-1.11.2_2+expat+geos+hdf5+netcdf+spatialite.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/gdal

---> Fetching distfiles for gdal

---> Attempting to fetch gdal-1.11.2.tar.gz from http://distfiles.macports.org/gdal

---> Verifying checksums for gdal

---> Extracting gdal

---> Applying patches to gdal

---> Configuring gdal

---> Staging gdal into destroot

---> Installing gdal @1.11.2_2+expat+geos+hdf5+netcdf+spatialite

---> Deactivating gdal @1.11.2_2+expat

---> Cleaning gdal

---> Activating gdal @1.11.2_2+expat+geos+hdf5+netcdf+spatialite

---> Cleaning gdal

---> Updating database of binaries

---> Scanning binaries for linking errors

---> No broken files found.

bash-3.2#

comment:20 in reply to:  18 Changed 5 years ago by larryv (Lawrence Velázquez)

Resolution: fixed
Status: newclosed

Yes, I can destroot gdal +hdf5 successfully now. I’m going to call this fixed by r137065.

comment:21 Changed 5 years ago by gbesanaostman@…

I tried doing it in my Mac:

$ sudo port clean gdal ---> Cleaning gdal

$ sudo port install gdal +curl +geos +hdf5 +netcdf ---> Computing dependencies for gdal ---> Fetching archive for gdal ---> Attempting to fetch gdal-1.11.2_2+curl+expat+geos+hdf5+netcdf.darwin_14.x86_64.tbz2 from http://packages.macports.org/gdal ---> Attempting to fetch gdal-1.11.2_2+curl+expat+geos+hdf5+netcdf.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/gdal ---> Attempting to fetch gdal-1.11.2_2+curl+expat+geos+hdf5+netcdf.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/gdal ---> Fetching distfiles for gdal ---> Verifying checksums for gdal ---> Extracting gdal ---> Applying patches to gdal ---> Configuring gdal ---> Building gdal Error: org.macports.build for port gdal returned: command execution failed Please see the log file for port gdal for details:

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/main.log

To report a bug, follow the instructions in the guide:

http://guide.macports.org/#project.tickets

Error: Processing of port gdal failed

Its not doing the destroot portion. Is there something I am doing wrong?

comment:22 in reply to:  21 Changed 5 years ago by larryv (Lawrence Velázquez)

Did you get the new hdf5?

% sudo port selfupdate
% sudo port upgrade outdated

comment:23 Changed 5 years ago by gbesanaostman@…

The selfupdate and upgrade did it! That step, i missed. So, after doing that, I got the hdf5 update and everything went well with gdal. Thanks a bunch!

Note: See TracTickets for help on using tickets.