Opened 5 years ago

Closed 21 months ago

#48251 closed defect (fixed)

libpcl @1.7.2: error: no member named 'GetCocoaServer' in 'vtkCocoaRenderWindowInteractorFix'

Reported by: jrd-freak@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: Raimondi (Israel Chauca Fuentes)
Port: libpcl

Description

sudo port install libpcl

Aborts some time during build.

OS version 10.10.4

Attachments (1)

main.log (559.0 KB) - added by jrd-freak@… 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by jrd-freak@…

Attachment: main.log added

comment:1 Changed 5 years ago by jrd-freak@…

The usual error:

--->  Building libpcl
Error: org.macports.build for port libpcl returned: command execution failed
Please see the log file for port libpcl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_libpcl/libpcl/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port libpcl failed

comment:2 Changed 5 years ago by Ionic (Mihai Moldovan)

Cc: vince@… added
Owner: changed from macports-tickets@… to luminans@…
Port: libpcl added

Thanks for the report.

Next time, please CC the maintainer(s) (shown by port info libpcl).

This seems to be caused by vtk removing GetCocoaServer() and was fixed by this commit: https://github.com/fran6co/pcl/commit/92a5c64e32b7a6a50d2ae20573a64b09f9a90ca5

Maintainers: please backport and test.

comment:3 Changed 5 years ago by Raimondi (Israel Chauca Fuentes)

Cc: macports@… added

Cc Me!

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Summary: libpcl fails to buildlibpcl @1.7.2: error: no member named 'GetCocoaServer' in 'vtkCocoaRenderWindowInteractorFix'

comment:5 Changed 2 years ago by mf2k (Frank Schima)

Cc: Veence removed
Owner: changed from luminans@… to Veence
Status: newassigned

See #57127.

comment:6 Changed 21 months ago by ctreleaven (Craig Treleaven)

Resolution: fixed
Status: assignedclosed

In 09d9af9c19e13051e440d3546edd73d6f00a877d/macports-ports (master):

libpcl: update to 1.9.1, maintainer timeout

Fixes: #40760
Fixes: #48251
Fixes: #56430

Note: See TracTickets for help on using tickets.