Opened 5 years ago

Closed 5 years ago

#48283 closed defect (duplicate)

llvm-3.3: Python detection error

Reported by: daryl@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: llvm-3.3

Description

I ran "sudo port upgrade outdated", and llvm-3.3 failed with this excerpt from the config.log file:

configure:12343: checking for python
configure:12361: found /opt/local/bin/python
configure:12378: result: /opt/local/bin/python
configure:12388: checking for python >= 2.5
configure:12399: result: not found
configure:12402: error: found python  (/opt/local/bin/python); required >= 2.5
See `config.log' for more details.

In fact, /opt/local/bin/python was a symlink to python 3.4. I changed it to link to python 2.7 and the upgrade succeeded.

It seems that config might be a little smarter about finding a compatible version of python (or better yet, adapting itself to python 3.) But since I've never done a port, I'm not too sure of that.

Change History (1)

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Keywords: Python removed
Resolution: duplicate
Status: newclosed
Type: requestdefect

Duplicate of #32575. A workaround:

% sudo port select --set python none
% sudo port upgrade llvm-3.3
% sudo port select --set python python34
Note: See TracTickets for help on using tickets.