Opened 5 years ago

Last modified 5 years ago

#48520 new defect

asymptote @2.35: +universal variant fails

Reported by: tobse_rave@… Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: asymptote

Description (last modified by ryandesign (Ryan Schmidt))

Hi, I'm completely new to MacPorts, so first of all thank you very much for your effort.

My system:
MacOS 10.10
Xcode 6.4 with CLT
MacPorts 2.3.3

Apart from Xcode, I set up everything especially to install asymptote on my computer. I tried to follow the guide and used 'sudo port install asymptote', which started to install a list of dependencies. It took a while, but apparently went fine, until the the installation of asymptote itself which didn't succeed. As recommended I tried to clean and redo it, and I also uninstalled and reinstalled, but the outcome didn't change.

By using the trace mode during, this was prompted in Terminal:

--->  Configuring asymptote
Warning: The following existing files were hidden from the build system by trace mode:
  /opt/local/bin/bison
  /opt/local/bin/flex
  /opt/local/bin/gm4
--->  Building asymptote
Warning: The following existing files were hidden from the build system by trace mode:
  /opt/local/bin/autoconf
  /opt/local/bin/automake
  /opt/local/bin/gawk
  /opt/local/bin/gmkdir
  /opt/local/bin/gsed
  /opt/local/bin/gunzip
  /opt/local/bin/pkg-config
Error: org.macports.build for port asymptote returned: command execution failed 

The log file of a clean install is attached as well, and I hope this ticket contains all necessary information to track down the issue.

Thanks in advance!

Attachments (1)

main.log (3.0 MB) - added by tobse_rave@… 5 years ago.

Change History (5)

Changed 5 years ago by tobse_rave@…

Attachment: main.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to mojca@…

In the future, please Cc the port maintainers (port info --maintainers asymptote), if any.

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Summary: asymptote 2.35 processing failedasymptote @2.35: +universal variant fails

The error shown in the log is:

ld: warning: ignoring file gc-7.4.2/.libs/libgc.a, file was built for archive which is not the architecture being linked (i386): gc-7.4.2/.libs/libgc.a

I get the same error, when I try to build with the universal variant. Looks like that was not tested for this port and does not work here. Until that's fixed, you could build asymptote without the universal variant; that worked for me.

comment:4 Changed 5 years ago by mojca (Mojca Miklavec)

I'm a bit tight with time right now, but one of you might want to check whether boehmgc +universal works as expected.

The developer of Asymptote would most probably accept any patches, but he is not an OS X user, so one of use would have to come up with a potential patch.

In case this is a high priority issue for whatever reason, please let me know.

Note: See TracTickets for help on using tickets.