Opened 4 years ago

Closed 4 years ago

#48542 closed defect (fixed)

putty @0.63 +gui build failure: 'gdk/gdkx.h' file not found

Reported by: gthb (Gunnlaugur Thor Briem) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: kurthindenburg (Kurt Hindenburg)
Port: putty

Description

Build of putty @0.63 +gui fails on missing file gdk/gdkx.h`, whether installing fresh or upgrading, with this salient bit in the log:

:info:build ccache /usr/bin/clang -D_REENTRANT -I/opt/local/include/gtk-2.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/pango-1.0 -I/opt/local/include/harfbuzz -I/opt/local/include/pango-1.0 -I/opt/local/include/cairo -I/opt/local/include/atk-1.0 -I/opt/local/include/cairo -I/opt/local/include/pixman-1 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/libpng16 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/libpng16 -I/opt/local/include/gdk-pixbuf-2.0 -I/opt/local/include/libpng16 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include    -Wall -pipe -Os -arch x86_64  -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64 -o puttygen cmdgen.o conf.o import.o misc.o notiming.o sshaes.o sshbn.o sshdes.o sshdss.o sshdssg.o sshmd5.o sshprime.o sshpubk.o sshrand.o sshrsa.o sshrsag.o sshsh256.o sshsh512.o sshsha.o time.o tree234.o uxcons.o uxgen.o uxmisc.o uxnoise.o uxstore.o libversion.a 
:info:build ./../unix/gtkfont.c:17:10: fatal error: 'gdk/gdkx.h' file not found
:info:build #include <gdk/gdkx.h>
:info:build          ^
:info:build ./../unix/gtkwin.c:23:10: fatal error: 'gdk/gdkx.h' file not found
:info:build #include <gdk/gdkx.h>
:info:build          ^
:info:build ./../unix/gtkdlg.c:11:10: fatal error: 'gdk/gdkx.h' file not found
:info:build #include <gdk/gdkx.h>
:info:build          ^
:info:build 1 error generated.

Building with -gui works.

The log shows ccache is enabled, but I tried also with it disabled; same result.

This is on Mac OS X 10.10.4, Xcode 6.4 Build version 6E35b.

Attachments (1)

putty-main.log (117.2 KB) - added by gthb (Gunnlaugur Thor Briem) 4 years ago.
main.log from the failing build

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by gthb (Gunnlaugur Thor Briem)

Attachment: putty-main.log added

main.log from the failing build

comment:1 Changed 4 years ago by gthb (Gunnlaugur Thor Briem)

OK, this is really because I have gtk2 +quartz installed, not the x11 variant, and putty's dependency on gtk2 is really a dependency on gtk2 +x11. Same problem for another MacPorts package at #42787 and same problem for putty in Homebrew at https://github.com/Homebrew/homebrew/issues/40951

I'm guessing there is no way to declare a dependency on a specific variant of a port? Tried depends_lib-append port:gtk2+x11 but it wasn't having it.

Last edited 4 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 in reply to:  1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Replying to gunnlaugur@…:

I'm guessing there is no way to declare a dependency on a specific variant of a port? Tried depends_lib-append port:gtk2+x11 but it wasn't having it.

The require_active_variants procedure in the active_variants 1.1 portgroup would have to be used to do that.

comment:3 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:4 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

done r139999

Note: See TracTickets for help on using tickets.