Opened 3 years ago

Closed 3 years ago

#48749 closed defect (fixed)

libmagic @ 5.24: checksum mismatch

Reported by: ksee.zelgadis@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: libmagic

Description

Hello! I have tried to install libmagic today and got a checksum mismatch error. Please see the log below:

version:1
:debug:main Executing org.macports.main (libmagic)
:debug:main Attempting ln -sf /Volumes/data/build.debug/var/macports/build/_Volumes_data_build.debug_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_file/libmagic/work /Volumes/data/build.debug/var/macports/sources/rsync.macports.org/release/tarballs/ports/sysutils/file/work
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Skipping completed org.macports.archivefetch (libmagic)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (libmagic)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:checksum checksum phase started at Fri Sep  4 06:07:01 MSD 2015
:notice:checksum --->  Verifying checksums for libmagic
:debug:checksum Executing org.macports.checksum (libmagic)
:info:checksum --->  Checksumming file-5.24.tar.gz
:debug:checksum Calculated (rmd160) is dab841250ce1961b02e918a84c3d1f53edb5594a
:error:checksum Checksum (rmd160) mismatch for file-5.24.tar.gz
:info:checksum Portfile checksum: file-5.24.tar.gz rmd160 cadf802b623e17b08abc842d600c2eb646487b66
:info:checksum Distfile checksum: file-5.24.tar.gz rmd160 dab841250ce1961b02e918a84c3d1f53edb5594a
:debug:checksum Calculated (sha256) is 379d44f42567bfe721c6d099789f1edac51660d129552fe2ccdb128e8e14c135
:error:checksum Checksum (sha256) mismatch for file-5.24.tar.gz
:info:checksum Portfile checksum: file-5.24.tar.gz sha256 802cb3de2e49e88ef97cdcb52cd507a0f25458112752e398445cea102bc750ce
:info:checksum Distfile checksum: file-5.24.tar.gz sha256 379d44f42567bfe721c6d099789f1edac51660d129552fe2ccdb128e8e14c135
:info:checksum The correct checksum line may be:
:info:checksum checksums           rmd160  dab841250ce1961b02e918a84c3d1f53edb5594a \
                    sha256  379d44f42567bfe721c6d099789f1edac51660d129552fe2ccdb128e8e14c135
:error:checksum org.macports.checksum for port libmagic returned: Unable to verify file checksums
:debug:checksum Error code: NONE
:debug:checksum Backtrace: Unable to verify file checksums
    while executing
"portchecksum::checksum_main org.macports.checksum"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:checksum Warning: targets not executed for libmagic: org.macports.activate org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:checksum Failed to install libmagic
:debug:checksum Registry error: wavpack not registered as installed & active.
    invoked from within
"registry_active $subport"
    invoked from within
"$workername eval registry_active \$subport"
:notice:checksum Please see the log file for port libmagic for details:
    /tmp/skl/SynfigStudio/Contents/Resources/var/macports/logs/_Volumes_data_build.debug_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_file/libmagic/main.log

Change History (6)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Cc: ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

There are many possible reasons why this might happen. Did you read wiki:FAQ#checksums and try to figure out what the cause was? Did you already run "sudo port clean --all libmagic" and then try again?

comment:3 Changed 3 years ago by ksee.zelgadis@…

Yes, I did all recommendations at checksums FAQ. Also tried "sudo port clean --all libmagic", but didn't helped. Here's additional info about mirrors:

--->  Computing dependencies for libmagic
--->  Fetching distfiles for libmagic
--->  Attempting to fetch file-5.24.tar.gz from http://distcache.FreeBSD.org/ports-distfiles/
--->  Attempting to fetch file-5.24.tar.gz from http://gentoo.tups.lv/source/distfiles/
--->  Verifying checksums for libmagic
Error: Checksum (rmd160) mismatch for file-5.24.tar.gz
Error: Checksum (sha256) mismatch for file-5.24.tar.gz
Error: org.macports.checksum for port libmagic returned: Unable to verify file checksums
Please see the log file for port libmagic for details:
    /tmp/skl/SynfigStudio/Contents/Resources/var/macports/logs/_Volumes_data_build.debug_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_file/libmagic/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port libmagic failed

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Thanks for these details. It appears that the gentoo.tups.lv server no longer provides these files, and in their place provides an HTML file directing users to a blog page.

I've removed this mirror from the list in r140020. If you run "sudo port clean --all libmagic" one more time, then wait 30 minutes, then run "sudo port selfupdate" and then try again, it should work.

comment:5 Changed 3 years ago by ksee.zelgadis@…

Works perfectly now. Thank you!

comment:6 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.