Opened 5 years ago

Closed 5 years ago

#48990 closed defect (duplicate)

coffee-script @1.3.3 - build failure - macports package pulling out-of-date source files?

Reported by: macports.org@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc:
Port: coffee-script

Description

Coffee-script fails to build. Log file from the build is attached.

I have latest nodejs @0.12.7, Macports 2.3.3, OS is El Capitan 10.11.1.

Googling the error message from the log, it looks like "path.existsSync" (referenced in file cake.js) has been deprecated in nodejs, should be "fs.existsSync" instead. This appears to be fixed in the latest coffee-script cake.js source file, so maybe the python package just needs to be updated to pull the latest coffee-script source files?

Attachments (1)

main.log (34.7 KB) - added by macports.org@… 5 years ago.
Log file from coffee-script build

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by macports.org@…

Attachment: main.log added

Log file from coffee-script build

comment:1 Changed 5 years ago by macports.org@…

One workaround that worked for me: install python package npm, then install coffee-script via npm instead:

$ sudo port install npm
$ sudo npm install coffee-script --global

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ryandesign@…

In the future, please Cc the port maintainers (port info --maintainers coffee-script), if any.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Note that npm and coffee-script are node packages, not python packages.

Yes, MacPorts coffee-script is very out of date. I'll call this a duplicate of #46893.

Note: See TracTickets for help on using tickets.